Bug 731267 - Display resolution has problem when boot guest with spice+qxl with multiple monitor
Summary: Display resolution has problem when boot guest with spice+qxl with multiple m...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: David Blechter
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 08:23 UTC by Qunfang Zhang
Modified: 2013-01-10 00:14 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-26 11:19:45 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of the desktop with high resolution (762.71 KB, image/png)
2011-08-17 08:23 UTC, Qunfang Zhang
no flags Details

Description Qunfang Zhang 2011-08-17 08:23:56 UTC
Created attachment 518608 [details]
Screenshot of the desktop with high resolution

Description of problem:
Boot guest with multiple monitor using spice and set the 2nd desktop (not main display) to a high resolution (for example 1920x1440), it displays incorrectly. Please refer to the screenshot.

Version-Release number of selected component (if applicable):
kernel-2.6.32-184.el6.x86_64
qemu-kvm-0.12.1.2-2.183.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot a windows guest with multiple monitor.
 /usr/libexec/qemu-kvm -m 2G -smp 4 -cpu cpu64-rhel6,+x2apic -drive file=/home/win7-64-virtio.qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device ide-drive,drive=drive-ide0-0-0,id=ide0-0-0 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device rtl8139,netdev=hostnet0,mac=00:10:1a:3b:20:1f,bus=pci.0,addr=0x4 -boot dc -uuid 6d59434d-3f1c-4558-afc3-37e2cc430d6b -rtc-td-hack -no-kvm-pit-reinjection -monitor stdio -name rhel6.1-32 -spice port=5930,disable-ticketing -vga qxl -usb -k en-us -global qxl-vga.vram_size=33554432 -device qxl,id=video1,vram_size=67108864,bus=pci.0,addr=0x5 -device virtio-serial-pci,id=virtio-serial0,max_ports=16,bus=pci.0,addr=0x7 -chardev socket,id=channel0,host=127.0.0.1,port=12345,server,nowait -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=channel0,id=channel0,name=com.redhat.rhevm.vdsm -chardev spicevmc,id=charchannel1,name=vdagent -device virtserialport,bus=virtio-serial0.0,nr=2,chardev=charchannel1,id=channel1,name=com.redhat.spice.0


2. Install qxl driver, virtio-serial driver, vdagent-win inside guest.

3. Right click on the desktop and bring up the display properties.
 - It should show 2 monitors now, and let you activate the display on the
second monitor.

4. Activate the second display by select the drop-down menu "extend desktop to this display", but do NOT check "Make this my main display"

5. Change the screen resolution of "monitor 2" to a larger one, such as 1920x1440.

  
Actual results:
If set the non-main display's resolution to a large value, it can not displays correctly. For the main display, it works well.

Expected results:
Should set the all the multiple monitors the any resolution.

Additional info:

Comment 2 RHEL Product and Program Management 2011-10-07 16:03:26 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 4 Alon Levy 2012-04-23 13:05:37 UTC
I can't see anything wrong with the secondary display, tested 2560x1440 and it seems fine, set a background image as you did in the display, except for it not being stretched to fill the display, I could move windows around, create folders/shortcuts. What exactly is wrong in the image you attached?

Alon

Comment 5 Qunfang Zhang 2012-04-25 05:03:45 UTC
Hi, Alon
From the attachment we could see the default windows 7 background is not fully fill up the display. There's some black screen around the guest's desktop.

Comment 6 Alon Levy 2012-04-25 09:48:12 UTC
(In reply to comment #5)
> Hi, Alon
> From the attachment we could see the default windows 7 background is not fully
> fill up the display. There's some black screen around the guest's desktop.

OK, I thought maybe there was something I missed. From my own attempts I couldn't get the image to be full screen, but it was just centered and not cut at all, so I couldn't reproduce the cut phenomena.

Alon

Comment 7 Qunfang Zhang 2012-04-26 06:23:42 UTC
Ok, I'll clear the needinfo flag, if there's anything need I do, please raise it again.

Comment 8 Alon Levy 2012-04-26 11:19:45 UTC
Qunfang,

 Sorry I wasn't clear enough. I think this isn't a bug - I can't reproduce, the "wallpaper image isn't stretched" that I'm seeing is not the same as the "wallpaper image is cut" that you put in the screenshot. I don't think the former is a bug as much as an RFE which you could open with the title "RFE: background wallpaper on secondary monitors should be stretchable".

Alon


Note You need to log in before you can comment on or make changes to this bug.