Bug 731278 - [cifs] Kernel 3.0 Panics
Summary: [cifs] Kernel 3.0 Panics
Keywords:
Status: CLOSED DUPLICATE of bug 727927
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jeff Layton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 09:00 UTC by subi.the.dream.walker
Modified: 2014-06-18 07:41 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-29 21:35:47 UTC


Attachments (Terms of Use)
kernel trace (3.46 KB, text/plain)
2011-08-17 09:00 UTC, subi.the.dream.walker
no flags Details
A longer trace (13.76 KB, text/plain)
2011-08-17 09:01 UTC, subi.the.dream.walker
no flags Details

Description subi.the.dream.walker 2011-08-17 09:00:32 UTC
Created attachment 518622 [details]
kernel trace

Description of problem:
Several seconds after mounting cifs, kernel halts.

Version-Release number of selected component (if applicable):
kernel 3.0.1
kernel 3.0.2

How reproducible:


Steps to Reproduce:
1. mount cifs, access the cifs vfs
2. wait
3.
  
Actual results:
kernel panic

Expected results:


Additional info:
attached please find some trace info.

Comment 1 subi.the.dream.walker 2011-08-17 09:01:42 UTC
Created attachment 518623 [details]
A longer trace

Comment 2 Jeff Layton 2011-08-17 10:26:16 UTC
Well, that's very odd -- it fell down inside of __kmalloc. Could you follow the directions here and post the listing of where it crashed?

    http://wiki.samba.org/index.php/LinuxCIFS_troubleshooting#Oopses

...also, what slab allocator are you using in this kernel? Something like this on the kernel config in the build directory should tell you:

$ egrep 'CONFIG_SL.?B' /path/to/.config
CONFIG_SLUB_DEBUG=y
# CONFIG_SLAB is not set
CONFIG_SLUB=y
CONFIG_SLABINFO=y
# CONFIG_SLUB_DEBUG_ON is not set
# CONFIG_SLUB_STATS is not set

Comment 3 subi.the.dream.walker 2011-08-17 11:43:03 UTC
the slab config is:

CONFIG_SLUB_DEBUG=y
# CONFIG_SLAB is not set
CONFIG_SLUB=y
CONFIG_SLABINFO=y
# CONFIG_SLUB_DEBUG_ON is not set
# CONFIG_SLUB_STATS is not set

don't have the time to run the gdb test right now. i'll post the result later. thanks.

Comment 4 Josh Boyer 2011-08-17 12:04:55 UTC
F16 is moving to 3.1-rc now.  While Jeff is looking, you might try the latest F16 kernel build from koji and see if it recreates.

Comment 5 Jeff Layton 2011-08-17 14:48:42 UTC
Thanks, I'll set the needinfo flag. Let me know when you have the gdb listing...

Comment 6 subi.the.dream.walker 2011-08-18 05:17:40 UTC
(In reply to comment #4)
> F16 is moving to 3.1-rc now.  While Jeff is looking, you might try the latest
> F16 kernel build from koji and see if it recreates.

I tried 3.1-rc2 and the panic is still there.

Comment 7 subi.the.dream.walker 2011-08-18 05:25:24 UTC
here is all the gdb lists.

(gdb) l *(__kmalloc+0x97)
0xffffffff810b21cf is in __kmalloc (mm/slub.c:1947).
1942    static void flush_cpu_slab(void *d)
1943    {
1944            struct kmem_cache *s = d;
1945
1946            __flush_cpu_slab(s, smp_processor_id());
1947    }
1948
1949    static void flush_all(struct kmem_cache *s)
1950    {
1951            on_each_cpu(flush_cpu_slab, s, 1);

(gdb) l *(kmem_cache_alloc+0x5f)
0xffffffff810b1cbf is in kmem_cache_alloc (mm/slub.c:1947).
1942    static void flush_cpu_slab(void *d)
1943    {
1944            struct kmem_cache *s = d;
1945
1946            __flush_cpu_slab(s, smp_processor_id());
1947    }
1948
1949    static void flush_all(struct kmem_cache *s)
1950    {
1951            on_each_cpu(flush_cpu_slab, s, 1);

=========
thanks

Comment 8 subi.the.dream.walker 2011-08-18 05:26:26 UTC
here is the gdb list.

(gdb) l *(__kmalloc+0x97)
0xffffffff810b21cf is in __kmalloc (mm/slub.c:1947).
1942    static void flush_cpu_slab(void *d)
1943    {
1944            struct kmem_cache *s = d;
1945
1946            __flush_cpu_slab(s, smp_processor_id());
1947    }
1948
1949    static void flush_all(struct kmem_cache *s)
1950    {
1951            on_each_cpu(flush_cpu_slab, s, 1);

(gdb) l *(kmem_cache_alloc+0x5f)
0xffffffff810b1cbf is in kmem_cache_alloc (mm/slub.c:1947).
1942    static void flush_cpu_slab(void *d)
1943    {
1944            struct kmem_cache *s = d;
1945
1946            __flush_cpu_slab(s, smp_processor_id());
1947    }
1948
1949    static void flush_all(struct kmem_cache *s)
1950    {
1951            on_each_cpu(flush_cpu_slab, s, 1);

=========
thanks

Comment 9 subi.the.dream.walker 2011-08-18 08:23:15 UTC
After changing the slab allocator to CONFIG_SLAB, the kernel oops inside another code piece.

(gdb) l *(__free_pages+0x1)
0xffffffff8108be68 is in __free_pages (/usr/src/linux/arch/x86/include/asm/atomic.h:25).
20       *
21       * Atomically reads the value of @v.
22       */
23      static inline int atomic_read(const atomic_t *v)
24      {
25              return (*(volatile int *)&(v)->counter);
26      }
27
28      /**
29       * atomic_set - set atomic variable

Comment 10 Jeff Layton 2011-08-18 10:38:25 UTC
Do you have /sbin/mount.cifs installed? If not then this patch may help:

    http://marc.info/?l=linux-cifs&m=131345112022031&w=2

...could you test it and let me know if it does?

Comment 11 Justin Piszcz 2011-08-18 10:41:16 UTC
I just tried this patch and it fixed the problem so far for me (no instant crash) but will follow up if there are further problems.

Justin.

Comment 12 subi.the.dream.walker 2011-08-18 11:08:44 UTC
(In reply to comment #10)
> Do you have /sbin/mount.cifs installed? If not then this patch may help:
> 
>     http://marc.info/?l=linux-cifs&m=131345112022031&w=2
> 
> ...could you test it and let me know if it does?

Patch applied, so far so good. Nice, thanks very much.

Comment 13 Jeff Layton 2011-08-25 10:24:47 UTC
Could you also test with the kernel here and let me know if it also works?

https://koji.fedoraproject.org/koji/taskinfo?taskID=3298071

Comment 14 subi.the.dream.walker 2011-08-25 11:57:45 UTC
(In reply to comment #13)
> Could you also test with the kernel here and let me know if it also works?
> 
> https://koji.fedoraproject.org/koji/taskinfo?taskID=3298071

yes it works.

Comment 15 Chuck Ebbert 2011-08-29 21:35:47 UTC

*** This bug has been marked as a duplicate of bug 727927 ***


Note You need to log in before you can comment on or make changes to this bug.