Bug 73128 - kdevelop tries to open wrong file
kdevelop tries to open wrong file
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdevelop (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 19:13 EDT by Need Real Name
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-26 10:18:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-30 19:13:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020801

Description of problem:
when a project is compiling, clicking on the error message in the window result
in "file not found".  the file that should be opening would be something like
this "/home/me/projects/myproject1/myproject1/main.c", however in the error
message it says that kdevelop is looking for "/home/me/projects/myproject1/main.c".

This problem was present on limbo as well.  I do not know how kdevelop handles
the messages, but it seems to be ignoring the second "entering directory" output
from make or something.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  create a new terminal-c project
2.  in main.c, add in the line "#warning click here"
3.  build all
4.  click on the warning that was generated, an error message will pop up
looking for the wrong file
	

Additional info:
Comment 1 grift 2002-10-20 14:03:28 EDT
I fixed the problem today... It requiers a kdevelop recompile.
The problem is caused by a "newline" or "\n" char value

For futher details on fixing the problem email me at grift@cs.sun.ac.za
or visit www.cs.sun.ac.za/~grift where I will make available the corrected 
kdevelop rpm

Werner
Comment 2 Ngo Than 2002-10-21 07:35:08 EDT
cool, could you please attach your fix here? so i can add it into next build. 

thanks
Comment 3 Ngo Than 2003-01-26 10:18:56 EST
It's fixed in 2.1.5-1

Note You need to log in before you can comment on or make changes to this bug.