Bug 731288 - wildcard matching testing failed in sdt_misc.exp
Summary: wildcard matching testing failed in sdt_misc.exp
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: systemtap
Version: 6.2
Hardware: All
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: qe-baseos-tools
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 09:43 UTC by Han Pingtian
Modified: 2011-12-06 15:18 UTC (History)
5 users (show)

Fixed In Version: systemtap-1.6-3
Doc Type: Bug Fix
Doc Text:
Cause The sdt_misc.exp test did not take into account that some of code in sdt_types.c was conditionally compiled, changing the number of probe points available in the code. Consequence The sdt_misc.exp test would fail on 32-bit and 64-bit x86 architectures because the number of probe points available would not match the expected value. Fix The sdt_misc.exp test takes into account the conditionally compiled code in sdt_types.c when checking for the correct number of probes points. Result The sdt_misc.exp test now passes on 32-bit and 64-bit x86 architectures.
Clone Of:
Environment:
Last Closed: 2011-12-06 15:18:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1517 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2011-12-06 00:50:46 UTC

Description Han Pingtian 2011-08-17 09:43:48 UTC
Description of problem:
On i686:
Running /usr/share/systemtap/testsuite/systemtap.base/sdt_misc.exp ...

MARK-LWD-LOOP -- 2011-08-16 04:32:10 --
FAIL: sdt_misc wildcard (40) V1_uprobe
FAIL: sdt_misc wildcard (40) V2_kprobe

MARK-LWD-LOOP -- 2011-08-16 04:37:10 --
FAIL: sdt_misc wildcard (40) V2_uprobe
FAIL: sdt_misc wildcard (40) V3_uprobe

On x86_64:
Running /usr/share/systemtap/testsuite/systemtap.base/sdt_misc.exp ...

MARK-LWD-LOOP -- 2011-08-16 04:38:23 --
FAIL: sdt_misc wildcard (48) V1_uprobe

MARK-LWD-LOOP -- 2011-08-16 04:43:23 --
FAIL: sdt_misc wildcard (48) V2_kprobe
FAIL: sdt_misc wildcard (48) V2_uprobe

MARK-LWD-LOOP -- 2011-08-16 04:48:24 --
FAIL: sdt_misc wildcard (48) V3_uprobe

I have sent a patch to upstream.


Version-Release number of selected component (if applicable):
systemtap-testsuite-1.6-1.el6
kernel-2.6.32-189.el6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 4 David Smith 2011-09-08 18:41:57 UTC
This one is fixed upstream by commit c51f7d9a6d14226ae76e071fddf6093c06602632:

<http://sourceware.org/git/gitweb.cgi?p=systemtap.git;a=commitdiff;h=c51f7d9a6d14226ae76e071fddf6093c06602632>

This patch should backport without any problems.

Comment 9 William Cohen 2011-11-14 20:10:17 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause
    The sdt_misc.exp test did not take into account that some of 
    code in sdt_types.c was conditionally compiled, changing the number
    of probe points available in the code.
Consequence
    The sdt_misc.exp test would fail on 32-bit and 64-bit x86 architectures
    because the number of probe points available would not match the
    expected value.
Fix
    The sdt_misc.exp test takes into account the conditionally compiled code in
    sdt_types.c when checking for the correct number of probes points.
Result
    The sdt_misc.exp test now passes on 32-bit and 64-bit x86 architectures.

Comment 10 errata-xmlrpc 2011-12-06 15:18:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1517.html


Note You need to log in before you can comment on or make changes to this bug.