Bug 731296 - kernels >= 2.6.40 break xrandr
Summary: kernels >= 2.6.40 break xrandr
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 09:55 UTC by Nils Philippsen
Modified: 2018-04-11 07:17 UTC (History)
13 users (show)

Fixed In Version: kernel-3.1.5-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-12 21:57:46 UTC


Attachments (Terms of Use)
dmesg with 2.6.41.1-1.fc15 (71.98 KB, text/plain)
2011-11-29 08:17 UTC, Martin Wilck
no flags Details
Xorg.0.log with 2.6.41.1-1.fc15 (36.16 KB, text/plain)
2011-11-29 08:18 UTC, Martin Wilck
no flags Details
modified kernel spec file (69.07 KB, text/plain)
2011-11-29 16:11 UTC, Martin Wilck
no flags Details

Description Nils Philippsen 2011-08-17 09:55:37 UTC
Description of problem:
On kernels >= 2.6.40:

Activating an external monitor which is connected via port extender/DVI when only the internal LVDS display is active on my Dell Latitude D830 with Intel GM965/GL960 graphics via GNOME Shell -> System Settings -> Display doesn't work (error message by the tool), external monitor stays blank.

Running e.g. "xrandr --output DVI1 --auto" blanks the internal LVDS display as well without obvious means to get it back (i.e. blindly attempting commands like "xrandr --output LVDS1 --auto" doesn't help).

Configuring/activating external monitors with the above tool as well as running xrandr commands works with the Fedora 15 GA kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.40-4.fc15.x86_64           <- doesn't work
kernel-2.6.40.3-0.fc15.x86_64         <- doesn't work
kernel-2.6.38.6-26.rc1.fc15.x86_64    <- works

xorg-x11-drv-intel-2.15.0-5.fc15.x86_64
mesa-dri-drivers-7.11-1.fc15.x86_64
mesa-dri-llvmcore-7.11-0.18.20110730.0.fc15.x86_64   <-- probably an unused remnant from a previous version of mesa, which I'll remove now

How reproducible:
Reproducible.

Steps to Reproduce:
See above.
  
Actual results:
Display configuration tool doesn't let me activate an external monitor, xrandr commands blank internal display as well which only lets me reboot the machine hard (use Alt-SysRq s+u+b, or turn it off then on again).

Expected results:
Display configuration tool lets me activate an externally connected monitor.

Additional info:
HW profile: http://www.smolts.org/client/show/pub_26629e99-e9eb-497e-979c-77d500d56daa

Attempts to configure the external display produced such kernel messages:

...
Aug 17 10:42:25 gibraltar kernel: [  123.650710] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:3]
Aug 17 10:42:29 gibraltar kernel: [  127.650120] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:3]
Aug 17 10:42:39 gibraltar kernel: [  137.644619] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:3]
Aug 17 10:42:44 gibraltar kernel: [  143.085827] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:3]
Aug 17 10:42:47 gibraltar kernel: [  145.645905] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:3]
Aug 17 10:43:06 gibraltar kernel: [  164.661685] [drm:drm_crtc_helper_set_config] *ERROR* failed to set mode on [CRTC:3]
...

Comment 1 Michael E Brown 2011-09-14 20:02:38 UTC
I seem to be having the exact same issue on a Dell Latitude D620, with the same, I believe, video chipset.

One note: if I boot up the machine with the external monitor connected, it works just fine (dual displays as expected), but if I suspend and then resume the machine without the monitor connected, it then breaks and wont connect to the external monitor ever again until I reboot.

An additional bug that I have noticed that seems to be related, on suspend/resume, X seems to die on resume about one out of four times.

Comment 2 Sergio Monteiro Basto 2011-10-11 21:04:27 UTC
seems to me that xrandr change the name of the devices.

# xrandr 
Screen 0: minimum 320 x 200, current 1280 x 800, maximum 8192 x 8192
eDP1 connected 1280x800+0+0 (normal left inverted right x axis y axis) 304mm x 190mm
   1280x800       60.1*+   40.0  (...)

so 
xrandr --output LVDS1 --auto, will not work 
but 
xrandr --output eDP1 --auto, works.

Comment 3 Matěj Cepl 2011-10-12 18:50:50 UTC
What's your DE? If it is XFCE or something similar, then this is a duplicate of bug 738084.

Comment 4 Nils Philippsen 2011-10-13 08:32:06 UTC
It's non-fallback GNOME 3/Shell.

Comment 5 Nils Philippsen 2011-11-02 09:08:53 UTC
Same issue on F-16 (i.e. same behavior and kernel messages), with these versions:

kernel-3.1.0-5.fc16.x86_64
xorg-x11-drv-intel-2.16.0-2.fc16.x86_64

Anything else I should check?

Comment 6 Nils Philippsen 2011-11-02 15:02:28 UTC
Ominous: woken up from suspend, I try to activate external monitor from GNOME Shell/System Settings/Display this morning, to no avail. A few hours later, my screen suddenly goes blank like on an unoccupied virtual console (black, with white underscore-cursor in top-left corner), but with the X11 mouse pointer visible and movable. At that point, the external monitor shows the same picture, but frozen (mouse cursor doesn't move). Try to press key like Alt+F<x> to get back to the desktop, then wiggling the mouse I seem to activate the GNOME Shell overview, which gets me my desktop back. Now activating the external display in settings works.

Comment 7 Nils Philippsen 2011-11-22 14:01:26 UTC
What I described in comment #6 was only a fluke, never happened again.

Comment 8 Martin Wilck 2011-11-29 08:11:35 UTC
I have the same issue here. With 2.6.40+, once the external display has been switched off (e.g. because I remove the laptop from the docking station), it can't be turned on any more. 

Making matters worse, because it's impossible to switch the DVI1 on, GNOME 3 remembers my display config as "DVI1 off" and switches off the external monitor immediately after I log in, and is unable to switch it on again. There is no way out of this situation except to boot 2.6.38.6-27.fc15 or earlier and switch the external display on with that kernel.

Comment 9 Martin Wilck 2011-11-29 08:17:09 UTC
Created attachment 537811 [details]
dmesg with 2.6.41.1-1.fc15

Comment 10 Martin Wilck 2011-11-29 08:18:03 UTC
Created attachment 537815 [details]
Xorg.0.log with 2.6.41.1-1.fc15

Comment 11 Martin Wilck 2011-11-29 13:17:49 UTC
I think I identified the cause of the problem. It's the Fedora patch "drm-intel-make-lvds-work.patch".

I compiled stock 3.0 with the Fedora config and saw no problem. Applied "drm-intel-make-lvds-work.patch", and the problem occurs just like with the Fedora kernel.

Comment 12 Martin Wilck 2011-11-29 16:09:00 UTC
I confirmed my previous result by building the Fedora kernel 2.6.41.1-1 skipping "drm-intel-make-lvds-work.patch". The problem is gone.

Comment 13 Martin Wilck 2011-11-29 16:11:41 UTC
Created attachment 538096 [details]
modified kernel spec file

spec file used to compile the kernel package. Note that it'd be possible to simply recompile i915.ko after reverting "drm-intel-make-lvds-work.patch" from the Fedora sources.

Comment 14 Martin Wilck 2011-11-29 16:20:42 UTC
Given that "drm-intel-make-lvds-work.patch" seems to have been in the Fedora kernel for long before the 2.6.40 update, and that problems with external monitors are observed only since 2.6.40, I speculate that this patch is incompatible with i915 as of 3.0.x/2.6.40 and above (possibly the problem that it's supposed to solve is already solved upstream?). Please comment.

Comment 15 Josh Boyer 2011-11-29 16:32:37 UTC
Thanks for taking the time to debug this.  We discussed the patch you highlighted and agree that dropping it is the right thing to do.

It has been dropped in Fedora git and the next build on f15/f16 should have that change.

Comment 16 Nils Philippsen 2011-11-30 11:55:59 UTC
Note that I'll be on vacation for a few days, so won't have the chance to test this until about mid of next week.

Comment 17 Nils Philippsen 2011-11-30 11:56:56 UTC
Ahh, forgot: thanks to Martin for digging into this. Much appreciated.

Comment 18 Martin Wilck 2011-11-30 12:16:54 UTC
Thank you. I was acting in my own interest :-)

Comment 19 Sergio Monteiro Basto 2011-12-03 12:46:28 UTC
hi, 
patch drm-intel-make-lvds-work.patch still on kernel-3.1.4-1.fc16.src.rpm ,
I am also interested to know what harm this patch do to my laptop.

Comment 20 Josh Boyer 2011-12-03 15:35:30 UTC
(In reply to comment #19)
> hi, 
> patch drm-intel-make-lvds-work.patch still on kernel-3.1.4-1.fc16.src.rpm ,
> I am also interested to know what harm this patch do to my laptop.

We haven't built a kernel with this change yet.  As far as I'm aware, it won't do actual harm to your laptop.  Things just won't work.

Comment 21 Fedora Update System 2011-12-09 20:23:58 UTC
kernel-3.1.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.1.5-1.fc16

Comment 22 Fedora Update System 2011-12-10 19:34:13 UTC
Package kernel-3.1.5-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.1.5-1.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16840/kernel-3.1.5-1.fc16
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2011-12-12 12:20:42 UTC
kernel-2.6.41.5-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.5-1.fc15

Comment 24 Fedora Update System 2011-12-12 21:57:46 UTC
kernel-3.1.5-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 25 Fedora Update System 2011-12-15 18:54:22 UTC
kernel-2.6.41.5-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.5-4.fc15

Comment 26 Fedora Update System 2011-12-22 01:18:07 UTC
kernel-2.6.41.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.41.6-1.fc15

Comment 27 Sergio Monteiro Basto 2011-12-22 01:36:19 UTC
(In reply to comment #20)
> (In reply to comment #19)
> > hi, 
> > patch drm-intel-make-lvds-work.patch still on kernel-3.1.4-1.fc16.src.rpm ,
> > I am also interested to know what harm this patch do to my laptop.
> 
> We haven't built a kernel with this change yet.  As far as I'm aware, it won't
> do actual harm to your laptop.  Things just won't work.

yeah , I mean, find things that wasn't work, and start work, anyway as I type I remember that I forgot to test my display port , but until now don't found any difference. 
Thanks


Note You need to log in before you can comment on or make changes to this bug.