This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 7313 - fails anydbm test with ndbm over db
fails anydbm test with ndbm over db
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-24 19:13 EST by Vilius Puidokas
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-04 19:23:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vilius Puidokas 1999-11-24 19:13:25 EST
I'm trying to build perl 5.003_03 on a RH 6.1 machine (i686 arch). Perl is
failing its AnyDBM module test (which is a perl interface to the ndbm
(libdb.so) library). The test assigns and reads a value on a tied hash
using a null key ($h{''}). When building perl on a RH 5.2 system using
glibc 2.0.7, this test works fine, but on our RH6.1 machine (glibc 2.1.2)
it fails because the assignment just doesn't work (the null key is
never added to the hash).

So, on 5.2, the perl code:

  $h{''} = 'foo';
  print "$h{''}\n";

will print "foo". But on 6.1 it prints an empty line. It looks like
this is a bug in the libdb library (although I'm not 100% certain).
Comment 1 Cristian Gafton 2000-01-04 19:23:59 EST
Take a look at the patch we have integrated into the perl RPM from RH 6.1 to see
a possible workaround for Perl's problems on fuguring out which library is
which.

Note You need to log in before you can comment on or make changes to this bug.