Bug 731309 - Cannot umount NFS mount containing spaces
Cannot umount NFS mount containing spaces
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nfs-utils (Show other bugs)
6.1
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Steve Dickson
yanfu,wang
: Regression, ZStream
Depends On: 702273
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-17 06:20 EDT by RHEL Product and Program Management
Modified: 2011-10-24 05:29 EDT (History)
13 users (show)

See Also:
Fixed In Version: nfs-utils-1.2.3-7.el6_1.1
Doc Type: Bug Fix
Doc Text:
Previously, the function responsible for parsing the /proc/mounts file was not able to handle single quote characters in the path name of a mount points entries. As a consequence, an NFS exported file system could not be unmounted if its mount point contained space characters. To fix this problem, the parsing routine has been rewritten so that it now parses entries in the /proc/mounts file properly. All NFS file systems now can be unmounted as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-24 05:29:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2011-08-17 06:20:55 EDT
This bug has been copied from bug #702273 and has been proposed
to be backported to 6.1 z-stream (EUS).
Comment 7 yanfu,wang 2011-10-12 06:54:45 EDT
reproduced on RHEL6.1 package:
[root@dell-pec6145-01 ~]# uname -a
Linux dell-pec6145-01.lab.bos.redhat.com 2.6.32-131.0.15.el6.x86_64 #1 SMP Tue May 10 15:42:40 EDT 2011 x86_64 x86_64 x86_64 GNU/Linux
[root@dell-pec6145-01 ~]# rpm -qa|grep nfs-utils
nfs-utils-1.2.3-7.el6.x86_64
nfs-utils-lib-1.1.5-3.el6.x86_64

[root@dell-pec6145-01 ~]# mount -t nfs hp-xw4550-01.rhts.eng.bos.redhat.com:/tmp/dir\ with\ spaces /mnt/dir\ with\ spaces
[root@dell-pec6145-01 ~]# mount
...
hp-xw4550-01.rhts.eng.bos.redhat.com:/tmp/dir with spaces on /mnt/dir with spaces type nfs (rw,vers=4,addr=10.16.65.42,clientaddr=10.16.40.146)
[root@dell-pec6145-01 ~]# umount /mnt/dir\ with\ spaces
/mnt/dir with spaces was not found in /proc/mounts
/mnt/dir with spaces was not found in /proc/mounts

verified on nfs-utils-1.2.3-7.el6_1.1 by manual, umount dir with spaces is work now.

Automation run on all arches and pass also:
i386: https://beaker.engineering.redhat.com/jobs/142127
x86_64: https://beaker.engineering.redhat.com/jobs/142128
ppc64: https://beaker.engineering.redhat.com/jobs/142129
s390x: https://beaker.engineering.redhat.com/jobs/142130
Comment 8 Miroslav Svoboda 2011-10-20 12:13:09 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously, the function responsible for parsing the /proc/mounts file was not able to handle single quote characters in the path name of a mount points entries. As a consequence, an NFS exported file system could not be unmounted if its mount point contained space characters. To fix this problem, the parsing routine has been rewritten so that it now parses entries in the /proc/mounts file properly. All NFS file systems now can be unmounted as expected.
Comment 9 errata-xmlrpc 2011-10-24 05:29:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1397.html

Note You need to log in before you can comment on or make changes to this bug.