Bug 73131 - firstboot detects sound card but does not restart esd
firstboot detects sound card but does not restart esd
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-soundcard (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 19:49 EDT by Ed Halley
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-15 17:39:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Halley 2002-08-30 19:49:40 EDT
Description of Problem:

  After installation, on the first user login, the firstboot program starts.

  It runs the sound card detector, and the sound card (an Audigy in my case)
  is detected, and can play a test sound successfully.

  After firstboot finishes, the sound configuration defaults to having no
  sound server running, and sound-generating programs such as tuxracer and
  xmms will produce no sound.

  The sound card detector utility can still play a test sound successfully.
  Other applications produce no sound.

  If the sound server is enabled, and the user logs out and back in, then
  sounds from programs like xmms and tuxracer work properly.

  The default behavior should have sounds available to applications in the
  first gnome session, as well as subsequent sessions, without manually
  enabling these.

Additional Information:

  (katzj@redhat.com states that the defaults are off in the upstream source,
  too, and that event sounds should be off because "they suck."  I'm not
  commenting on the event sounds, but on the proper operation of sound
  servers for sound-generating applications such as xmms and tuxracer.)
Comment 1 Brent Fox 2002-11-22 14:01:39 EST
I don't seem to have this problem.  When I do a fresh install, I can start xmms
and hear music without having to change anything.  The default volume isn't very
loud, but it certainly seems audible.

However, I've had numerous people tell me that the default is so low that they
can't hear it.  It makes me wonder if the default sound level doesn't have
something to do with the hardware.  I have two identical test machines at my
desk.  Both have integrated Cirrus Logic sound cards.  One machine also has a
PCI SoundBlaster.  The default sound for the SoundBlaster is much louder than
the Cirrus Logic, which is very quiet.  I'm not sure if there's much I can do
about this...
Comment 2 Brent Fox 2002-11-22 14:07:26 EST
However, on my test box which is a fresh install of 8.0, esd gets started when
you log into Gnome.  If this is not the case on your machine, it sounds like esd
is the problem, not redhat-config-soundcard.
Comment 3 Brent Fox 2003-01-15 17:39:12 EST
I have been unable to reproduce this problem with both 8.0 and our latest
internal trees.  Resolving as 'worksforme'

Note You need to log in before you can comment on or make changes to this bug.