Bug 73133 - initrd assisted bootup fails if no /initrd directory
initrd assisted bootup fails if no /initrd directory
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
8.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Erik Troan
David Lawrence
http://www.unixgods.org/~tilo/redhat_...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 20:10 EDT by Hans Ecke
Modified: 2007-04-18 12:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-05 23:44:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hans Ecke 2002-08-30 20:10:07 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux; , en_US, en) 
 
Description of problem: 
If a RH 7.2, 7.3 or 8.0beta system boots using an init ramdisk, the bootup 
will fail if no /initrd directory exists. This is bad for several reasons: 
 
* the boot process should not die because of such a simple problem 
 
* most sysadmins will not know about this fact. upon encountering an empty 
directory /initrd they might just delete it, figuring it to be some random 
directory a runaway program created. the next time they reboot - weeks later - 
how is anybody to know what the reason for the sudden failure is? 
 
* the error message "pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 
2" is absolutely unhelpful and cryptic. It rather suggests that mounting root 
does not work, the initramdisk is outdated or something like that. 
 
I filed this bugreport under "mkinitrd" since the error occurs inside its 
bootup script. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1.set up a system to boot using an initramdisk  
2.test that it boots correctly 
3.rmdir /initrd 
4.reboot 
	 
 
Actual Results:  the boot process stops with error messages like this: 
 
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2 
Freeing unused kernel memory: 220k freed 
Kernel panic: No init found.  Try passing init= option to kernel. 
 
 
Expected Results:  it should boot without a problem 
 
Additional info:
Comment 1 Emilio Riva 2002-09-25 08:39:12 EDT
I've just discovered this same solution by myself after 4-hours of fear!!!
the problem seems to be simple, but it should be fixed soon please!!
Comment 2 Hans Ecke 2002-10-16 20:05:49 EDT
Changed version to 8.0. Maybe this will increase visibility.
Comment 3 Jeremy Katz 2003-01-05 23:44:32 EST
Your system will also fail to boot if you do 'rm -rf /etc' but people don't tend
to go around doing that.  There isn't anything that can be done at this point
because the root filesystem isn't mounted read-write yet and so we can't create
the directory we need if it fails to exist.

Note You need to log in before you can comment on or make changes to this bug.