Bug 731337 - kdump says: "not all arguments converted during string formatting"
Summary: kdump says: "not all arguments converted during string formatting"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.3
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Guangze Bai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 11:36 UTC by Caspar Zhang
Modified: 2015-02-08 21:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-08 15:43:51 UTC


Attachments (Terms of Use)
proposed patch (892 bytes, patch)
2011-08-17 11:36 UTC, Caspar Zhang
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1436 normal SHIPPED_LIVE v7 bug fix and enhancement update 2011-11-08 23:28:41 UTC

Description Caspar Zhang 2011-08-17 11:36:33 UTC
Created attachment 518658 [details]
proposed patch

Description of problem:

kdump gives the following error message:

Subtest initialize:
Checking required packages:
kexec-tools-2.0.0-188.el6.x86_64
crash-5.1.1-2.el6.x86_64
kernel-debuginfo-2.6.32-131.0.15.el6.x86_64
Checking kdump configuration
Found crashkernel=129M@0M boot parameter
Kernel panic reboot timeout is 1
Adding core_collector = makedumpfile -d 31 to /etc/kdump.conf
Error: test raised exception:
not all arguments converted during string formatting
copying attachments...
checking directory /var/log/v7/runs/4/kdump 
Skipping output.log
saveOutput: /var/log/v7/runs/4/kdump/output.log
Warning: could not merge output XML, reading as text file.
no element found: line 1, column 0
Return value was 1

which was caused by the following codes:

215             if self.getTestServer() and self.getTestServer() != "unknown":
216                 # Note: the assumption is that the environment for the SUT is the same as the environment 
217                 # for the server being used - both have the same server directory setting.
218                 net = "%s:%s/export" % (self.getTestServer(), self.environment.getServerDirectory(), self.environment.getServerExport())
219                 print "Adding net %s to %s" % (net, self.kdumpConfigPath)
220                 configFile.addParameter("net", net)
221                 restart = True

a patch to fix this issue has been attached.

Version-Release number of selected component (if applicable):
1.4 R16

How reproducible:
always

Comment 4 Caspar Zhang 2011-10-21 15:03:14 UTC
This bug doesn't need a TechNote because of:

a) it was discovered in a v7 1.4 intermediate version, and
b) it was discovered by a Red Hat associate only.

Comment 5 errata-xmlrpc 2011-11-08 15:43:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html

Comment 6 errata-xmlrpc 2011-11-08 18:32:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1436.html


Note You need to log in before you can comment on or make changes to this bug.