Bug 731340 - anaconda rescue mode fail
Summary: anaconda rescue mode fail
Keywords:
Status: CLOSED DUPLICATE of bug 730714
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda
Version: 6.2
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 691780
TreeView+ depends on / blocked
 
Reported: 2011-08-17 11:54 UTC by Michal Kovarik
Modified: 2011-08-17 12:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-17 12:09:25 UTC


Attachments (Terms of Use)

Description Michal Kovarik 2011-08-17 11:54:23 UTC
Description of problem:
After select Continue in anaconda rescue mode anaconda crashes and an exception occured.  

How reproducible:
always

Steps to Reproduce:
1. append "rescue" to anaconda boot parameters 
2. choose language, installation source
3. select "Continue" in Rescue dialog
  
Actual results:
Traceback (most recent call last):
File "/usr/bin/anaconda", line 858, in <module>
rescue.runRescue(anaconda, instClass)
File "/usr/lib/anaconda/rescue.py", line 327, in runRescue
storage.storageInitialize(anaconda)
File "/usr/lib/anaconda/storage/__init__.py", line 103, in storageInitialize storage.reset()
File "/usr/lib/anaconda/storage/__init__.py", line 408, in reset
100, 0.03, pulse=True)
TypeError: progressWindow() takes exactly 4 non-keyword arguments (5 given)

Comment 1 Radek Vykydal 2011-08-17 12:09:25 UTC

*** This bug has been marked as a duplicate of bug 730714 ***


Note You need to log in before you can comment on or make changes to this bug.