Bug 731341 - tcp_wrappers show testsuite regressions in RPMdiff
Summary: tcp_wrappers show testsuite regressions in RPMdiff
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: tcp_wrappers
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Jakub Jelen
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks: 836160
TreeView+ depends on / blocked
 
Reported: 2011-08-17 11:56 UTC by Miroslav Vadkerti
Modified: 2015-11-11 09:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-11 09:30:09 UTC


Attachments (Terms of Use)

Comment 1 Miroslav Vadkerti 2011-08-17 11:57:52 UTC
The developer is willing to fix this issue

Comment 2 RHEL Product and Program Management 2011-08-17 13:11:05 UTC
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux maintenance release. Product Management has 
requested further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed 
products. This request is not yet committed for inclusion in an Update release.

Comment 3 RHEL Product and Program Management 2011-10-07 16:07:27 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 6 Suzanne Yeghiayan 2012-02-14 23:13:41 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 RHEL Product and Program Management 2012-07-10 06:26:30 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 8 RHEL Product and Program Management 2012-07-11 01:51:59 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 9 RHEL Product and Program Management 2012-09-07 05:17:48 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.

Comment 11 Jakub Jelen 2015-11-09 16:06:52 UTC
OK. For further readers. I see this rpmdiff is related to build with relro patch. But even if I return back before the relro patch, the build log is still the same.

This message was not introduced by tcp_wrappers patch, but appeared as an consequence of gcc update (see root logs for respective packages in brew).

This is bad coding standard related to pointer aliasing [1] and fix would require to rework ip/ipv6 handling. At this point I would rather be for the way "do not touch this if it works" and there is no demand nor future (deprecation in RHEL7?).

[1] http://cellperformance.beyond3d.com/articles/2006/06/understanding-strict-aliasing.html


Note You need to log in before you can comment on or make changes to this bug.