Bug 731343 - [xfs/xfstests 225] fiemap tester failed with 512 blocksize
Summary: [xfs/xfstests 225] fiemap tester failed with 512 blocksize
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: fs-maint
QA Contact: Filesystem QE
URL:
Whiteboard:
Depends On:
Blocks: 1068914
TreeView+ depends on / blocked
 
Reported: 2011-08-17 12:00 UTC by Eryu Guan
Modified: 2016-03-15 11:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1068914 (view as bug list)
Environment:
Last Closed: 2015-12-11 16:42:51 UTC


Attachments (Terms of Use)

Description Eryu Guan 2011-08-17 12:00:24 UTC
Description of problem:
xfstests 225 failed on xfs with 512 block size. It's fine with 1024/2048/4096 block size.

log:
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2011/08/1208/120871/248728/2693715/13665692//test_log--kernel-filesystems-xfs-xfstests-225.log

Version-Release number of selected component (if applicable):
kernel-2.6.32-189.el6

How reproducible:
100%

Steps to Reproduce:
1. yum install rh-tests-kernel-filesystems-xfs-xfstests -y
2. cd /mnt/tests/kernel/filesystems/xfs/xfstests; ./install_all.sh
3. TEST_PARAM_FSTYPE=xfs TEST_PARAM_TEST_DEV=/dev/sda5 TEST_PARAM_SCRATCH_DEV=/dev/sda6 TEST_PARAM_BLKSIZE=512 make run
  
Actual results:
test fail

Expected results:
test pass

Additional info:
This is not a regression, it also fails on rhel6.1. It's the first time we test on xfs with 512 block size.

Failed recipe:
https://beaker.engineering.redhat.com/jobs/120871

Comment 1 Dave Chinner 2011-08-23 09:05:52 UTC
(In reply to comment #0)
> Description of problem:
> xfstests 225 failed on xfs with 512 block size. It's fine with 1024/2048/4096
> block size.
> 
> log:
> http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2011/08/1208/120871/248728/2693715/13665692//test_log--kernel-filesystems-xfs-xfstests-225.log

Are you sure you are testing with 512 byte block size? From the output in the above link:

FSTYP         -- xfs (non-debug)
PLATFORM      -- Linux/x86_64 hp-dc5800-01 2.6.32-188.el6.x86_64
MKFS_OPTIONS  -- -f -bsize=4096 /dev/sda6
MOUNT_OPTIONS -- -o context=system_u:object_r:nfs_t:s0 /dev/sda6 /mnt/testarea/scratch

Which says you are actually testing 4k block size. I can't reproduce this failure on my test box with any block size. e.g 512 byte blocks:

$ sudo MKFS_OPTIONS="-b size=512" ./check 225
FSTYP         -- xfs (non-debug)
PLATFORM      -- Linux/x86_64 rhel61-1 2.6.32
MKFS_OPTIONS  -- -f -b size=512 /dev/vdb
MOUNT_OPTIONS -- -o context=system_u:object_r:nfs_t:s0 /dev/vdb /mnt/scratch

225 3s ... 2s
Ran: 225
Passed all 1 tests

Comment 2 Eryu Guan 2011-08-23 10:41:24 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > Description of problem:
> > xfstests 225 failed on xfs with 512 block size. It's fine with 1024/2048/4096
> > block size.
> > 
> > log:
> > http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2011/08/1208/120871/248728/2693715/13665692//test_log--kernel-filesystems-xfs-xfstests-225.log
> 
> Are you sure you are testing with 512 byte block size? From the output in the
> above link:
> 
> FSTYP         -- xfs (non-debug)
> PLATFORM      -- Linux/x86_64 hp-dc5800-01 2.6.32-188.el6.x86_64
> MKFS_OPTIONS  -- -f -bsize=4096 /dev/sda6
> MOUNT_OPTIONS -- -o context=system_u:object_r:nfs_t:s0 /dev/sda6
> /mnt/testarea/scratch

Yes, I'm sure the TEST_DEV is mkfs'ed with 512 block size, the MKFS_OPTIONS here shows mkfs options of SCRATCH_DEV, I used /dev/sda5 as TEST_DEV and /dev/sda6 as SCRATCH_DEV in beaker testing.
> 
> Which says you are actually testing 4k block size. I can't reproduce this
> failure on my test box with any block size. e.g 512 byte blocks:
> 
> $ sudo MKFS_OPTIONS="-b size=512" ./check 225
> FSTYP         -- xfs (non-debug)
> PLATFORM      -- Linux/x86_64 rhel61-1 2.6.32
> MKFS_OPTIONS  -- -f -b size=512 /dev/vdb
> MOUNT_OPTIONS -- -o context=system_u:object_r:nfs_t:s0 /dev/vdb /mnt/scratch
> 
> 225 3s ... 2s
> Ran: 225
> Passed all 1 tests

I can reproduce this manually, eg. (here I used /dev/sda6 as TEST_DEV)
mkfs -t xfs -b size=512 -f /dev/sda6
mount /dev/sda6 /mnt/testarea/test
seed=`date +%s`
[root@dell-pec6145-01 xfstests]# /var/lib/xfstests/src/fiemap-tester -q -S -s $seed -p 0 -r 200 /mnt/testarea/test/testfile
ERROR: FIEMAP claimed there was data (H) at block 8 that should have been a hole, and FIBMAP confirmed that it was allocated, but it should be filled with 0's, but it was not so you have a big problem!
ERROR: found an allocated extent where a hole should be: 8
map is 'HDHHDDDDHH83'
logical: [       8..      17] phys:      566..     575 flags: 0x001 tot: 10
Problem comparing fiemap and map
[root@dell-pec6145-01 xfstests]# /var/lib/xfstests/src/fiemap-tester -q -s $seed -p 0 -r 200 /mnt/testarea/test/testfile
ERROR: FIEMAP claimed there was data (H) at block 8 that should have been a hole, and FIBMAP confirmed that it was allocated, but it should be filled with 0's, but it was not so you have a big problem!
ERROR: found an allocated extent where a hole should be: 8
map is 'HDHHDDDDHH83'
logical: [       8..      17] phys:      566..     575 flags: 0x001 tot: 10
Problem comparing fiemap and map

I tried 1024/2048/4096 block size and no error found by this way.

Comment 5 RHEL Product and Program Management 2011-10-07 15:44:52 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 10 Eric Sandeen 2015-12-11 16:42:51 UTC
# uname -a
Linux bp-05.lab.msp.redhat.com 2.6.32-555.el6.x86_64 #1 SMP Fri Apr 17 16:28:17 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux

# rpm -q xfsprogs
xfsprogs-3.1.1-14.el6.x86_64


# MKFS_OPTIONS="-b size=512" ./check generic/225
FSTYP         -- xfs (non-debug)
PLATFORM      -- Linux/x86_64 bp-05 2.6.32-555.el6.x86_64
MKFS_OPTIONS  -- -f -b size=512 /dev/sdb2
MOUNT_OPTIONS -- -o context=system_u:object_r:nfs_t:s0 /dev/sdb2 /mnt/scratch

generic/225 25s ...
 160s
Ran: generic/225
Passed all 1 tests

# xfs_info /mnt/scratch
meta-data=/dev/sdb2              isize=256    agcount=4, agsize=10485760 blks
         =                       sectsz=512   attr=2, projid32bit=0
data     =                       bsize=512    blocks=41943040, imaxpct=25
         =                       sunit=0      swidth=0 blks
naming   =version 2              bsize=4096   ascii-ci=0
log      =internal               bsize=512    blocks=20480, version=2
         =                       sectsz=512   sunit=0 blks, lazy-count=1
realtime =none                   extsz=4096   blocks=0, rtextents=0

# src/fiemap-tester -q -S -p 0 -r 200 /mnt/scratch/testfile
# src/fiemap-tester -q -S -s `date +%s` -p 0 -r 200 /mnt/scratch/testfile
#


Note You need to log in before you can comment on or make changes to this bug.