Red Hat Bugzilla – Bug 73138
gnome-libs should obsolete db1
Last modified: 2008-05-01 11:38:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020820
Description of problem:
both db1-1.85-8 and gnome-libs-22.214.171.124.90-20 both contain
The opinion around here seems to be that gnome-libs should not obsolete db1,
because then anyone with db1 installed would get gnome-libs when they upgrade.
but most likely they don't _need_ db1 as nothing is using it anymore.
As things stand now, I see no clean way to upgrade: I have a system with db1,
and a lot of old packages using libdb.so.2 from db1.
I can't upgrade one of those old packages, e.g. gnumeric, since it requires
gnome-libs >= 1.4.1.
I can't upgrade gnome-libs, since it conflicts with files from db1. Adding all
the old packages in the same gigantic upgrade would not help, it would still
conflict with db1.
I can't remove db1 since all the old packages depend on it.
There is no way to start here! But if gnome-libs did obsolete db1, as would be
logical, it provides what db1 provides, then everything would run fine.
It sounds to me that you are avoiding this in because of a limitation in the
upgrade logic. When upgrading, the obsolete tag is apparently assumed to mean
more than it actually says. But if so that is a problem with the upgrade logic,
and should be fixed there.
*** This bug has been marked as a duplicate of 58942 ***
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.