Bug 73138 - gnome-libs should obsolete db1
gnome-libs should obsolete db1
Status: CLOSED DUPLICATE of bug 58942
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
9
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 22:09 EDT by Jim Radford
Modified: 2008-05-01 11:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2002-08-30 22:09:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020820

Description of problem:
both db1-1.85-8 and gnome-libs-1.4.1.2.90-20 both contain

 /usr/bin/db1_dump185
 /usr/lib/libdb1.so.2
 /usr/lib/libdb1.a
Comment 1 Havoc Pennington 2002-09-04 14:51:22 EDT
The opinion around here seems to be that gnome-libs should not obsolete db1,
because then anyone with db1 installed would get gnome-libs when they upgrade.
but most likely they don't _need_ db1 as nothing is using it anymore.
Comment 2 Göran Uddeborg 2002-11-27 07:29:27 EST
As things stand now, I see no clean way to upgrade:  I have a system with db1,
and a lot of old packages using libdb.so.2 from db1.

I can't upgrade one of those old packages, e.g. gnumeric, since it requires
gnome-libs >= 1.4.1.

I can't upgrade gnome-libs, since it conflicts with files from db1.  Adding all
the old packages in the same gigantic upgrade would not help, it would still
conflict with db1.

I can't remove db1 since all the old packages depend on it.

There is no way to start here!  But if gnome-libs did obsolete db1, as would be
logical, it provides what db1 provides, then everything would run fine.

It sounds to me that you are avoiding this in because of a limitation in the
upgrade logic.  When upgrading, the obsolete tag is apparently assumed to mean
more than it actually says.  But if so that is a problem with the upgrade logic,
and should be fixed there.
Comment 3 Havoc Pennington 2003-01-07 16:36:07 EST

*** This bug has been marked as a duplicate of 58942 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.