Bug 73139 - gnome-libs conflicts with db1
gnome-libs conflicts with db1
Status: CLOSED DUPLICATE of bug 58942
Product: Red Hat Linux
Classification: Retired
Component: gnome-libs (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-30 22:12 EDT by Jim Radford
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jim Radford 2002-08-30 22:12:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1b) Gecko/20020820

Description of problem:
both db1-1.85-8 and gnome-libs-1.4.1.2.90-20 both contain

 /usr/bin/db1_dump185
 /usr/lib/libdb1.so.2
 /usr/lib/libdb1.a

Either gnome-libs probably shouldn't provide these files since if you  obsolete
db1 then you can't have db1-devel installed.
Comment 1 Havoc Pennington 2002-09-04 14:53:27 EDT
See explanation on #73138 - do we need an explicit Conflicts? The fact that the
files conflict should be enough right... 

db1-devel isn't intended to be installable; the point of moving db1 into
gnome-libs was to kill any compilation vs. db1.
Comment 2 Jim Radford 2002-09-04 17:27:19 EDT
I think adding an explicit conflict is the least that should be done.  Just
leaving conflicting files seems rude.  Do I have to crosscheck every file from
every package just to decide what to install?  Why not just leave db1 as a
separate package?  Clearly it is required by gnome-libs otherwise it wouldn't be
there.  Why hide that fact?
Comment 3 Havoc Pennington 2003-01-07 16:39:19 EST

*** This bug has been marked as a duplicate of 58942 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:49:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.