Bug 731433 - RFE: matahari init script shouldn't allow multiple instances of the same agent
Summary: RFE: matahari init script shouldn't allow multiple instances of the same agent
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: matahari
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Andrew Beekhof
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 16:30 UTC by Dave Johnson
Modified: 2011-12-06 11:39 UTC (History)
4 users (show)

Fixed In Version: matahari-0.4.2-7.el6
Doc Type: Enhancement
Doc Text:
No description required
Clone Of:
Environment:
Last Closed: 2011-12-06 11:39:54 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1569 normal SHIPPED_LIVE matahari bug fix and enhancement update 2011-12-06 00:39:06 UTC

Description Dave Johnson 2011-08-17 16:30:09 UTC
Description of problem:
=================================
Noticed that you can start multiple instances of the same agent on a box, we probably should prevent that. 

Version-Release number of selected component (if applicable):
============================================================
v0.4.2-6

How reproducible:
===================
100%

Steps to Reproduce:
1.  install matahari agent
2.  /etc/init.d/matahari-<agent> start
3.  /etc/init.d/matahari-<agent> start
4.  /etc/init.d/matahari-<agent> start
5.  ps -ef | grep matahari
  
Actual results:
===================
notice multiple instances of the same agent

Expected results:
====================
only on instance

Additional info:
====================
Same thing occurs in libvirt-qmf

Comment 2 Zane Bitter 2011-08-17 17:04:07 UTC
Note that the preferred way to start a daemon is with "service matahari-<agent> start", since that should ensure a consistent environment.

I can't reproduce this issue on Fedora 15 (haven't tried RHEL).

Comment 3 Andrew Beekhof 2011-08-18 04:35:33 UTC
Reproduced on RHEL

Comment 4 Andrew Beekhof 2011-08-18 04:40:24 UTC
A related patch has been committed upstream: https://github.com/beekhof/matahari/commit/d8d6ee9

Comment 5 Andrew Beekhof 2011-08-18 04:41:51 UTC
[root@pcmk-1 ~]# killall -9 matahari-qmf-hostd
[root@pcmk-1 ~]# /etc/init.d/matahari-host status
matahari-qmf-hostd is stopped
[root@pcmk-1 ~]# /etc/init.d/matahari-host start
matahari-qmf-hostd is stopped
Starting the matahari-host daemon:                         [  OK  ]
[root@pcmk-1 ~]# /etc/init.d/matahari-host start
matahari-qmf-hostd (pid 1436) is running...
[root@pcmk-1 ~]# ps axf | grep qmf-host
 1446 pts/0    S+     0:00  |       \_ grep qmf-host
 1436 ?        Ssl    0:00 matahari-qmf-hostd --reconnect=yes --daemon

Comment 8 Dave Johnson 2011-08-19 19:55:51 UTC
good 2 go in v0.4.2-7

[root@hp-bl260cg5-01 init.d]# ./matahari-host start; ./matahari-network start; ./matahari-service start; ./matahari-sysconfig start
matahari-qmf-hostd is stopped
Starting the matahari-host daemon: [  OK  ]
matahari-qmf-networkd is stopped
Starting the matahari-network daemon: [  OK  ]
matahari-qmf-serviced is stopped
Starting the matahari-service daemon: [  OK  ]
matahari-qmf-sysconfigd is stopped
Starting the matahari-sysconfig daemon: [  OK  ]

[root@hp-bl260cg5-01 init.d]# ./matahari-host start; ./matahari-network start; ./matahari-service start; ./matahari-sysconfig start
matahari-qmf-hostd (pid 8965) is running...
matahari-qmf-networkd (pid 8976) is running...
matahari-qmf-serviced (pid 8987) is running...
matahari-qmf-sysconfigd (pid 8999) is running...

[root@hp-bl260cg5-01 init.d]# ./matahari-host start; ./matahari-network start; ./matahari-service start; ./matahari-sysconfig start
matahari-qmf-hostd (pid 8965) is running...
matahari-qmf-networkd (pid 8976) is running...
matahari-qmf-serviced (pid 9072) is running...
matahari-qmf-sysconfigd (pid 8999) is running...

[root@hp-bl260cg5-01 init.d]# ps -ef | grep matahari
root      8965     1  0 15:51 ?        00:00:01 matahari-qmf-hostd --reconnect=yes --broker ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com --port 49000 --daemon
root      8976     1  0 15:51 ?        00:00:00 matahari-qmf-networkd --reconnect=yes --broker ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com --port 49000 --daemon
root      8999     1  0 15:51 ?        00:00:00 matahari-qmf-sysconfigd --reconnect=yes --broker ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com --port 49000 --daemon
root      9072     1  0 15:53 ?        00:00:00 matahari-qmf-serviced --reconnect=yes --broker ibm-x3650-02.ovirt.rhts.eng.bos.redhat.com --port 49000 --daemon
root      9102  8834  0 15:54 pts/0    00:00:00 grep matahari
[root@hp-bl260cg5-01 init.d]#

Comment 9 Russell Bryant 2011-11-16 21:43:04 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
No description required

Comment 10 errata-xmlrpc 2011-12-06 11:39:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1569.html


Note You need to log in before you can comment on or make changes to this bug.