Bug 73145 - cdrom will not eject data cds but will eject audio cds
cdrom will not eject data cds but will eject audio cds
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: autorun (Show other bugs)
7.3
athlon Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 00:30 EDT by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-01 10:58:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-31 00:30:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
when first opening cdrom drive by physcially pressing the button (root or user),
it opens.  After inserting an audio cd, one is able to eject the cd by
physcially pressing the eject button on the cdrom.  After inserting a data cd,
one must use the eject <cdrom name> command.  The physical push of the cdrom
button to eject a data cd will not work.  However, one is able to open a konsole
(i'm using kde) and execute the eject command, which successfully ejects the cd.

gimme a newbie break as this was the closest component I could find to enter bug  =)

I am using an athlong xp 1700+, spacewalker motherboard (specs at
http://www.shuttleonline.com/spec.php3?model=ak32l), 256 ddr ram, 350 watt power
supply, Emachine 333id DVD ROM, norcent rw400 cdrw drive.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start OS
2. insert non cd-audio disc
3. try to physically eject cd by pushing eject button on cdROM/RW drive.
	

Actual Results:  cd would not eject.

Expected Results:  cd should have ejected from drive.

Additional info:

after running the tail -f /var/log/messages     command, the following line
appeared in the log.

Aug 30 22:53:53 localhost kernel: Device not ready.  Make sure there is a disc
in the drive.

after ejecting the cd using the eject <cdrom name> command, no additional
information appeared in the log.
Comment 1 Mike A. Harris 2002-09-01 03:40:26 EDT
This isn't a cdp bug, it is a "feature".  When you insert a data CD,
it is mounted automagically.  Yes, I find this incredibly annoying too.

The solution that I use personally is:  rpm -e magicdev autofs amd

I don't know if that is suitable for your purposes however.

Reassigning to best-guess component.
Comment 2 Owen Taylor 2002-09-01 10:58:22 EDT
 - magicdev is not used under KDE; the program there is called 'autorun'.
   (Not as fun to say 'rpm -e autorun'?....)

 - There is a config GUI for magicdev, if the reporter was using GNOME
   (Not as fun to say "go to the CD Properties dialog" and uncheck
   "Mount CD when inserted"?)

I don't, in any case, believe that what the reporter is complaining
about is that his CD was mounted, but that it can't be ejected
through the button.

Unfortunately, fixing this is really hard... according to the ATAPI
spec a softwired button (that is, when you press it, it asks the
OS to eject the CD, so the OS can unmount, then eject, like when
you type 'eject') is possible, but hardware that implements that
is apparently vanishingly rare.

So, the only way to do it is to make things robust against a CD
suddenly vanishing... Alan Cox had a "user space NFS daemon" that
handled the CD drive that was supposed to do something like this,
but I never tried it out. There is an inherent problem that you
really don't want to eject the CD while a program is accessing it,
because most programs won't properly handle an IO error.

I'm going to close this WONTFIX; not because we don't want to fix it,
but because I think if we find a way fix it, we'd remember it without
a bug, and there isn't really a good component for this bug.

Note You need to log in before you can comment on or make changes to this bug.