Bug 731490 - Need build completion notification outside of tailing imagefactory.log using CLI
Summary: Need build completion notification outside of tailing imagefactory.log using CLI
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 1.0.0
Hardware: All
OS: Linux
medium
high
Target Milestone: rc
Assignee: Imre Farkas
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 18:51 UTC by William Henry
Modified: 2018-11-28 21:38 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:10:32 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0588 normal SHIPPED_LIVE new packages: imagefactory 2012-05-15 22:31:27 UTC

Description William Henry 2011-08-17 18:51:04 UTC
Description of problem:

When building for ec2 using upload there is no way of knowing that a build has completed or failed unless you tail the imagefactory.log file.

Should the aeolus-image build block?  The completion 0% doesn't tell you anything and a build can take a long time. 

Perhaps another tool is planned to take care of this form a UI perspective but what happens with the CLI tools?

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Angus Thomas 2011-09-22 12:24:44 UTC
We're in the process in planning a build & push UI within the Conductor web app itself which will address this.

Comment 2 wes hayutin 2011-09-28 16:38:02 UTC
making sure all the bugs are at the right version for future queries

Comment 4 Ken Keiter 2011-12-16 16:11:06 UTC
According to sseago, this issue has been resolved in the build/push UI in the latest Aeolus rev.

Comment 5 wes hayutin 2011-12-16 17:13:36 UTC
Status examples:
aeolus-cli status --targetimage $target_image     # status of target image build
aeolus-cli status --providerimage $provider_image # status of provider image push

[root@qeblade31 conductor]# rpm -qa | grep aeolus
aeolus-conductor-daemons-0.7.0-4.fc16.noarch
aeolus-all-0.7.0-4.fc16.noarch
rubygem-aeolus-image-0.2.0-1.fc16.noarch
aeolus-conductor-0.7.0-4.fc16.noarch
rubygem-aeolus-cli-0.2.0-3.fc16.noarch
aeolus-conductor-doc-0.7.0-4.fc16.noarch
aeolus-configure-2.4.0-3.fc16.noarch
[root@qeblade31 conductor]#

Comment 6 wes hayutin 2011-12-16 17:18:58 UTC
[root@qeblade31 conductor]# aeolus-cli list --images
ID                                       Name                               OS         OS Version     Arch       Description                                           
------------------------------------     ------------------------------     ------     ----------     ------     -------------------------------------------------     
52bc7864-5c7b-420e-8774-ba1a936b84f2     RHEL6-Basic                        RHEL-6     1              x86_64     RHEL61 x86_64                                         
ce03c517-8f51-4d85-94a8-72a92afa3cbf     RHEL5-Basic                        RHEL-5     U7             x86_64     RHEL57 x86_64                                         
36d71e79-d49d-4744-92ce-7453686a001a     RHEL6-Basic                        RHEL-6     1              x86_64     RHEL61 x86_64                                         
8ac49e19-55ca-454c-ae4e-a68678e6ac41     RHEL5-Basic                        RHEL-5     U7             x86_64     RHEL57 x86_64                                         
7356dfd5-32b5-41d1-8e6c-9526f1ff6e82     RHEL6_VMWareTools                  RHEL-6     1              x86_64     RHEL61 x86_64 and VMWareTools                         
cc5a3fe6-c684-40b3-b272-876fc996df99     rhel6_2_x86_64_with_rhev-agent     RHEL-6     2              x86_64     rhel 6.2 x86_64 template with rhev v3.0 agent pkg     

[root@qeblade31 conductor]# aeolus-cli list --builds 52bc7864-5c7b-420e-8774-ba1a936b84f2
ID                                       Image                                    
------------------------------------     ------------------------------------     
ccee82f8-35f8-469d-95c5-7aeb06dbc6aa     52bc7864-5c7b-420e-8774-ba1a936b84f2     

[root@qeblade31 conductor]# aeolus-cli list --targetimages ccee82f8-35f8-469d-95c5-7aeb06dbc6aa
ID                                       Status       Build                                    
------------------------------------     --------     ------------------------------------     
291164a4-777f-4bcf-9591-66a2627f35d7     COMPLETE     ccee82f8-35f8-469d-95c5-7aeb06dbc6aa     

[root@qeblade31 conductor]# aeolus-cli status --targetimage 291164a4-777f-4bcf-9591-66a2627f35d7
Build Status: COMPLETE
[root@qeblade31 conductor]# aeolus-cli list --providerimages 291164a4-777f-4bcf-9591-66a2627f35d7
ID                                       Target Identifier                                  Provider     Status       Target Image                             
------------------------------------     ----------------------------------------------     --------     --------     ------------------------------------     
f884f33c-fb11-4c1a-b9ce-92b8beec8858     Mock_mock_f884f33c-fb11-4c1a-b9ce-92b8beec8858     mock         COMPLETE     291164a4-777f-4bcf-9591-66a2627f35d7     

[root@qeblade31 conductor]# aeolus-cli status  --providerimage f884f33c-fb11-4c1a-b9ce-92b8beec8858
Push Status: COMPLETE
[root@qeblade31 conductor]#

Comment 8 Ken Keiter 2012-01-31 14:56:11 UTC
Appears that this is not updating in the UI as intended. Assigning to ifarkas per athomas's request.

Comment 9 errata-xmlrpc 2012-05-15 20:10:32 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0588.html


Note You need to log in before you can comment on or make changes to this bug.