Bug 7315 - gen-index crashes (segmentation fault)
gen-index crashes (segmentation fault)
Status: CLOSED DEFERRED
Product: Red Hat Powertools
Classification: Retired
Component: gnats (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-24 19:34 EST by hdcg
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-01-12 20:35:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hdcg 1999-11-24 19:34:35 EST
We were running gnats-3.2 (compiled locally) by near two years. The
original RedHat Linux version installed was 5.1, but the system had been
running on 5.2 most time. At November 20th 1999, we installed 6.0 (I mean,
erased everything except user data), and installed gnats-3.108-1.i386.rpm.
We replicated our configuraion and copied data. But we are unable to access
PRs. I tried gen-index, but It crashed.
The core file was on /usr/share/gnats/gnats-db, so I issued:
gdb /usr/libexec/gnats/gen-index /usr/share/gnast/gnats-db/core
GNU gdb 4.18
Copyright 1998 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...
(no debugging symbols found)...
Core was generated by `/usr/libexec/gnats/gen-index'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libc.so.6...done.
Reading symbols from /lib/ld-linux.so.2...done.
#0  0x4005b81a in _IO_vfprintf (s=0x0, format=0x8050090 "%s",
ap=0xbffffc64)
    at vfprintf.c:1013
1013	vfprintf.c: No such file or directory.
(gdb) where
#0  0x4005b81a in _IO_vfprintf (s=0x0, format=0x8050090 "%s",
ap=0xbffffc64)
    at vfprintf.c:1013
#1  0x400636f7 in fprintf (stream=0x0, format=0x8050090 "%s") at
fprintf.c:32
#2  0x8049617 in strcpy () at ../sysdeps/generic/strcpy.c:30
#3  0x804998a in strcpy () at ../sysdeps/generic/strcpy.c:30
#4  0x4002ecb3 in __libc_start_main (main=0x8049864 <strcpy+1432>, argc=1,
    argv=0xbffffce4, init=0x8048e6c, fini=0x804ff5c <getopt_long_only+124>,
    rtld_fini=0x4000a350 <_dl_fini>, stack_end=0xbffffcdc)
    at ../sysdeps/generic/libc-start.c:78
(gdb) quit
I tried gnats-3.110-2.i386.rpm (powertools 6.1) but It crashed too.
I'm going to find gnats-3.2 and recompile it on 6.0. We have 594 PRs,
and really need the system up and running.
Comment 1 Tim Powers 1999-12-06 07:20:59 EST
Sorry for the delay getting to you. Did gnats-3.2 work for you?

------- Email Received From  "'Aztec Eagle' Turbo" <turbo@cie.unam.mx> 12/06/99 11:10 -------
Comment 2 Tim Powers 2000-01-12 20:35:59 EST
I am closing this bug since there hasn't been any response since my last
message. You can reopen this bug if you want to resume.

Note You need to log in before you can comment on or make changes to this bug.