Bug 731516 - Testing Provider Account to confirm it's correct.
Summary: Testing Provider Account to confirm it's correct.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-conductor
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
Assignee: Jiri Tomasek
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 19:08 UTC by William Henry
Modified: 2012-05-15 21:52 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 21:52:33 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0583 normal SHIPPED_LIVE new packages: aeolus-conductor 2012-05-15 22:31:59 UTC

Description William Henry 2011-08-17 19:08:42 UTC
Description of problem:

It's been said that (a) testing the Provider tests the Provider account is valid. It's been said you can (b) test the Provider Account directly.


However for (a) you can test for successfully for different provider regions successfully even though the Provider Account might be set up ofr only one of those regions. So that's confusing.

For the (b) claim there is no Test button on the "Provider Account" tab.  There should be one there. If the test is currently in Provider then it needs to be moved to Provider Account. Provider test should test for connection to the provider and a separate Provider Account test should confirm credentials.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 wes hayutin 2011-08-18 14:24:16 UTC
Angus you had some comments for this bug

Comment 2 wes hayutin 2011-09-28 16:39:09 UTC
making sure all the bugs are at the right version for future queries

Comment 4 Jiri Tomasek 2011-10-17 11:40:29 UTC
fixed in commit ad614b734c05b688bf9602243596417e74d6836d

Comment 5 Aziza Karol 2011-10-20 10:12:58 UTC
Provider test and Provider Account test option is available for each provider.

Provider test tests for connection to the provider. 
Provider Account test confirm credentials.


verified on:
[root@nec-em6 templates]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.5.0-0.20111018184108gitf5c4fc6.fc15.noarch
aeolus-all-0.5.0-0.20111018184108gitf5c4fc6.fc15.noarch
rubygem-aeolus-cli-0.1.0-3.20111003133323git9451323.fc15.noarch
aeolus-configure-2.2.0-1.20111007151942git26136f2.fc15.noarch
aeolus-conductor-0.5.0-0.20111018184108gitf5c4fc6.fc15.noarch
aeolus-conductor-daemons-0.5.0-0.20111018184108gitf5c4fc6.fc15.noarch
rubygem-aeolus-image-0.1.0-3.20111003170706git8f23238.fc15.noarch

Comment 7 errata-xmlrpc 2012-05-15 21:52:33 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0583.html


Note You need to log in before you can comment on or make changes to this bug.