Bug 731527 - Using Snapshot V Upload for EC2 images
Summary: Using Snapshot V Upload for EC2 images
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: imagefactory
Version: 0.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
Assignee: Mike Orazi
QA Contact: wes hayutin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 19:28 UTC by William Henry
Modified: 2011-12-08 13:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-30 19:37:09 UTC


Attachments (Terms of Use)

Description William Henry 2011-08-17 19:28:30 UTC
Description of problem:

Be default the imagefactory.conf includes the following line:

  "ec2_build_style": "snapshot",

Customers may have lots of company standard images and kickstart definitions that they use internally and want to use these same images in the cloud. In order for customers to use their own images/repos for building images for EC2 they need to edit the imagefactory.conf file and change the above line to:

  "ec2_build_style": "upload",

However no ALL images build using this instance of imagefactory will use upload. 

It would be nice to choose at build time what build sytle to use rather than having to edit the default style in the imagefactory.conf.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lalancette 2011-08-17 20:26:59 UTC
Yes, definitely.  This is a problem that we'll need to fix shortly, as it is going to start causing pain.  Luckily it shouldn't be too hard to do.

Comment 2 Mike Orazi 2011-08-18 13:54:37 UTC
We may want to get some additional input from Hugh Brock & Chris Morgan on this.

Comment 3 wes hayutin 2011-08-18 14:22:18 UTC
uploading customer created RHEL images to ec2 *may* lead to some heart burn for customers. Chris may want to comment for ec2.

Comment 8 Chris Morgan 2011-08-19 17:17:29 UTC
There is no reconciliation, then.  We only support images that are in the providers catalog and certified.  Most clouds do not have import capability anyway due to the licensing concerns.

Comment 9 wes hayutin 2011-08-30 19:37:09 UTC
uploading RHEL is not supported..
closing

Comment 11 wes hayutin 2011-12-08 13:50:21 UTC
perm close


Note You need to log in before you can comment on or make changes to this bug.