Bug 731535 - kdissert is dead -> semantik
Summary: kdissert is dead -> semantik
Keywords:
Status: CLOSED DUPLICATE of bug 738057
Alias: None
Product: Fedora
Classification: Fedora
Component: kdissert
Version: 15
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 20:04 UTC by Gregor Tätzner
Modified: 2011-09-14 17:16 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-14 17:16:41 UTC


Attachments (Terms of Use)
fix desktop file (513 bytes, patch)
2011-08-18 09:04 UTC, Gregor Tätzner
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 738057 None None None Never

Internal Links: 738057

Description Gregor Tätzner 2011-08-17 20:04:59 UTC
I don't know if this is the right place, but since several years semantik exists. It's the official KDE4 successor of kdissert. Why do you keep maintaining such an old and unsupported software? Could you provide a semantik package? I, for myself, can't do it because there is a linking problem when you build semantik on fedora 15.
see page: http://code.google.com/p/semantik/issues/detail?id=12

project: http://www.freehackers.org/~tnagy/kdissert.html

Comment 1 Rex Dieter 2011-08-17 20:20:34 UTC
Because no one's stepped up to work on packaging semantik... yet.

(I personally started on it awhile back, but never finished the work)

Comment 2 Rex Dieter 2011-08-17 20:41:48 UTC
ok, here's what I've got, builds on f14, f15,

http://rdieter.fedorapeople.org/rpms/semantik/

Comment 3 Gregor Tätzner 2011-08-18 09:04:36 UTC
Created attachment 518821 [details]
fix desktop file

Comment 4 Gregor Tätzner 2011-08-18 09:07:57 UTC
The desktop file is broken (doesn't show up in the menu). And another observation with the new desktop file: no semantik icon in the menu.

Anyway thank you for your effort and great job!

Comment 5 Rex Dieter 2011-08-18 12:10:11 UTC
please do send patches to semantik upstream too please. :)

to be clear, i'm providing these as-is (i've not the time/interest currently), *hopefully* so someone else can take it and maintain it properly.

Comment 6 Rex Dieter 2011-08-18 12:14:33 UTC
fwiw, 

the missing Exec= entry is a big *doh* missing piece alright.

Categories need not be modified, afaict, it shows up for me in Office/ menu (on kde), and I do see the icon (/usr/share/icons/hicolor/22x22/apps/semantik.png is used)

Comment 7 Rex Dieter 2011-09-14 17:16:41 UTC
yay, thanks for submitting it and offering to maintain things moving forward.

*** This bug has been marked as a duplicate of bug 738057 ***


Note You need to log in before you can comment on or make changes to this bug.