Bug 731540 - Inconsistency in in-place-edit html
Summary: Inconsistency in in-place-edit html
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-17 20:19 UTC by Jeff Weiss
Modified: 2019-09-26 13:19 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:00 UTC


Attachments (Terms of Use)

Description Jeff Weiss 2011-08-17 20:19:18 UTC
Description of problem:
In other parts of the ui, the automation can use the same locator for both the input fields for creation, and the in-place-edit.

For example, when creating a provider, the name textbox has attribute name="provider[name]", and the textbox on the in-place-edit page has the same attribute.

But this is not the case for Sync Plans.  On create it uses name="sync_plan[name]" and in-place-edit is
name="plan[name]".

just need to replace 'plan' with 'sync_plan' for all the in-place-edit fields.

Version-Release number of selected component (if applicable):
katello-0.1.63-1.git.76.3e01b6b.fc14.noarch

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Brad Buckingham 2011-08-29 17:02:31 UTC
commit: e0f19f409cd5b7598f2f754e0c8961678de69308

changed usage of plan to sync_plan within the edit UI.

Comment 2 Jeff Weiss 2011-09-22 01:40:55 UTC
Verified e0f19f409cd5b7598f2f754e0c8961678de69308

Comment 5 Mike McCune 2013-08-16 17:53:48 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.