Bug 731547 - Cannot load on x86_64 EL6
Cannot load on x86_64 EL6
Status: CLOSED DUPLICATE of bug 708550
Product: Fedora EPEL
Classification: Fedora
Component: mod_auth_cas (Show other bugs)
el6
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Miller
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-17 16:47 EDT by Eric Eisenhart
Modified: 2011-08-17 16:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 16:49:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Eisenhart 2011-08-17 16:47:48 EDT
Description of problem:

Install mod_auth_cas breaks httpd.  Appears to be looking for some SSL symbols that aren't there or aren't loaded.

mod_auth_cas requires doesn't include any SSL things, but I do have mod_ssl and openssl packages installed.

Easily fixed by removing mod_auth_cas package

Version-Release number of selected component (if applicable):
mod_auth_cas.x86_64 0:1.0.8.1-2.el6
redhat-release-server-6Server-6.1.0.2.el6.x86_64
epel-release-6-5.noarch
httpd-2.2.15-9.el6.x86_64
mod_ssl-2.2.15-9.el6.x86_64

How reproducible:
Very

Steps to Reproduce:
1. yum -y install mod_auth_cas
2. service httpd restart
  
Actual results:
Stopping httpd:                                            [  OK  ]
Starting httpd: httpd: Syntax error on line 221 of /etc/httpd/conf/httpd.conf: Syntax error on line 6 of /etc/httpd/conf.d/auth_cas.conf: Cannot load /etc/httpd/modules/mod_auth_cas.so into server: /etc/httpd/modules/mod_auth_cas.so: undefined symbol: SSL_connect
                                                           [FAILED]


Expected results:
Stopping httpd:                                            [  OK  ]
Starting httpd:                                            [  OK  ]
Comment 1 Eric Eisenhart 2011-08-17 16:49:37 EDT

*** This bug has been marked as a duplicate of bug 708550 ***

Note You need to log in before you can comment on or make changes to this bug.