Bug 73155 - Network install hangs at "Starting install process, this may take several minutes..."
Network install hangs at "Starting install process, this may take several min...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-31 07:34 EDT by Stephen Jacob
Modified: 2007-04-18 12:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 11:21:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Jacob 2002-08-31 07:34:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/0

Description of problem:
On a Nanocube (http://www.lugs.org.sg/twiki/bin/view/Nanocubes/WebHome)
with 32Mb of system RAM, doing an HTTP network install:

The install process just sits and seemingly hangs at the message "Starting
install process, this may take several minutes...". Hard disk seems to be
active, but no other signs of activity. No network activity. No activity on any
consoles. No errors on any consoles.

Left it in this state for approx. 90 mins before I gave up and rebooted.

Upgraded machine from 32Mb to 128Mb and tried again.

Message above only stayed up for a couple of minutes and the install proceeded
healthily from there.

Perhaps 32Mb is just insufficient? ... or perhaps it was insanely swapping
constantly? I was unable to determine which.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Acquire a Nanocube :-) ... and don't upgrade the amount of memory.
2. Copy the RH7.3 CDs to a HTTP-accessible directory somewhere.
3. Boot the Nanocube. Use boot target 'redhat' from DiskOnChip.
4. Select Network install, method HTTP, and specify the server you set up in #2.
5. Partition disks and stuff.
6. Select "Everything" in package selection.
7. Watch the system seemingly hang for a really long time (or forever?).

Actual Results:  It hung. :)

Expected Results:  It shouldn't have hung?

Additional info:
Comment 1 Michael Fulbright 2002-09-02 11:21:01 EDT
If you can get me one I'll take a look at this problem. I can do 32MB installs
on 'normal' PCs w/o a problem.

Can you ping it from another machine when its 'hung'?
Comment 2 Stephen Jacob 2002-09-03 20:29:06 EDT
I don't think I could get hold of another Nanocube myself, even if I wanted to,
unfortunately.

Additionally, I have a report from a colleague of mine who has one that he was
able to install Red Hat on his Nanocube with only 32Mb installed in it, however
he did so overnight so has no idea how long it took to get through the process.

I suspect that it was just insanely slow and had I left it long enough it might
have successfully finished. I'd rather not blow away the system I have finally
got set up on it, so I think we should probably just consider this resolved
unless you have some other way to follow it up and particularly want to do so.

The machine was not hung; just the process was (seemingly) hung. I was able to
interact with it on one of the other consoles... I suspect I could have pinged it.

Note You need to log in before you can comment on or make changes to this bug.