Bug 731579 - exiting console in interactive virsh causes subsequent commands to fail
Summary: exiting console in interactive virsh causes subsequent commands to fail
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 21:34 UTC by Dave Allan
Modified: 2016-04-26 14:43 UTC (History)
6 users (show)

Fixed In Version: libvirt-0.9.4-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-09-08 02:50:45 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Dave Allan 2011-08-17 21:34:55 UTC
After connecting to the console in interactive virsh and
disconnecting, I often see all subsequent commands fail:

virsh # dominfo foo
error: failed to get domain 'foo'
error: An error occurred, but the cause is unknown

virsh # dominfo foo
error: failed to get domain 'foo'
error: no call waiting for reply with prog 536903814 vers 1 serial 300

virsh # define bar.xml
error: Failed to define domain from bar.xml
error: no call waiting for reply with prog 536903814 vers 1 serial 301

Closing and reopening the interactive virsh session makes the problem
go away.

Powering down the guest while the console is connected has made the
problem 100% reproducible in the 4 or 5 tries I've given it.


Version-Release number of selected component (if applicable):
0.9.4-4

Comment 3 Dave Allan 2011-08-22 12:38:14 UTC
Powering off the domain from within the domain caused it to reproduce reliably for me.

Comment 7 Vivian Bian 2011-09-07 09:53:55 UTC
Hi Dave, 
tested with following pkgs , and didn't encounter this bug 
But since we can't reproduce this bug even with the old version .Would you please help confirm the patch ? 

libvirt-0.9.4-9.el6
qemu-kvm-0.12.1.2-2.185.el6
kernel-2.6.32-193.el6

1. configure guest grub with "console=tty0 console=ttyS0,115200n8" appended in
the kernel command line 
2. configure guest with serial device added 
    <serial type='pty'>
      <source path='/dev/pts/5'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
3. start guest 
4. enter interactive mode of virsh 
   # virsh  
   Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # console test1
Connected to domain test1
Escape character is ^]
localhost.localdomain login: root
Password: 
[root@localhost ~]# shutdown -h now

initctl: Event failedm root@localhost.localdomain
Stopping sshd: [  OK  ]
Shutting down postfix: [  OK  ]
Stopping crond: [  OK  ]
Stopping auditd: 
...
...
Halting system...

virsh # dominfo rhel6
Id:             -
Name:           rhel6
UUID:           888fe8e8-9b0b-3542-6aec-b120d06d94fb
OS Type:        hvm
State:          shut off
CPU(s):         1
Max memory:     1048576 kB
Used memory:    1048576 kB
Persistent:     yes
Autostart:      disable
Managed save:   no
Security model: selinux
Security DOI:   0

And tried to make a connect-disconnect loop during guest shutdown , but never meet this bug .

Comment 8 Dave Allan 2011-09-07 15:12:09 UTC
I was testing using a libvirt that I built myself, so perhaps that's the source of the difference.  Like I said, it was 100% reproducible for me, so if you've tested it with the latest libvirt and it's not present, I think you can close as WORKSFORME.

Comment 9 Vivian Bian 2011-09-08 02:50:45 UTC
According to comment 8 , close this bug as worksforme . Once this bug is encountered , we'll open it again


Note You need to log in before you can comment on or make changes to this bug.