Bug 731583 - garbled console in interactive virsh session
Summary: garbled console in interactive virsh session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt
Version: 6.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Daniel Berrangé
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-17 21:37 UTC by Dave Allan
Modified: 2016-04-26 14:29 UTC (History)
6 users (show)

Fixed In Version: libvirt-0.9.4-8.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 11:49:16 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1513 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2011-12-06 01:23:30 UTC

Description Dave Allan 2011-08-17 21:37:14 UTC
If I enter and exit the console of a domain multiple times in one interactive virsh session, I see garbled console output that's consistent with multiple consoles being open at the same time.

0.9.4-4

Comment 2 Vivian Bian 2011-08-18 07:42:31 UTC
Dave , would  you please help confirm if the following stuff is the exact reproducer for this bug ? 

tested with libvirt-0.9.4-4

steps :
1. configure guest grub with "console=tty0 console=ttyS0,115200n8" appended in
the kernel command line 
2. configure guest with serial device added 
    <serial type='pty'>
      <source path='/dev/pts/5'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
3. start guest 
4. enter interactive mode of virsh 
   # virsh  
   Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # console test1
Connected to domain test1
Escape character is ^]
�  Welcome to Red Hat Enterprise Linux Client
Starting udev: 
virsh # console test1
Connected to domain test1
Escape character is ^]

[/sbin/fsck
untin quotas:  
virsh # console test1
Connected to domain test1
Escape character is ^]
6_64 on an x86_646_64 on an x86_64x86_64 on an x86_64

After times of Enter-Exit loop , we get the garbled console output in
interactive virsh session . 

Additional info:
This can be only seen in virsh interactive mode .

Comment 3 Dave Allan 2011-08-22 12:16:47 UTC
Yes, that's exactly it.

Comment 7 Vivian Bian 2011-09-07 09:28:06 UTC
tested with 
libvirt-0.9.4-9.el6
qemu-kvm-0.12.1.2-2.185.el6
kernel-2.6.32-193.el6

steps :
1. configure guest grub with "console=tty0 console=ttyS0,115200n8" appended in
the kernel command line 
2. configure guest with serial device added 
    <serial type='pty'>
      <source path='/dev/pts/5'/>
      <target port='0'/>
      <alias name='serial0'/>
    </serial>
3. start guest 
4. enter interactive mode of virsh 
   # virsh  
   Welcome to virsh, the virtualization interactive terminal.

Type:  'help' for help with commands
       'quit' to quit

virsh # console test1
Connected to domain test1
Escape character is ^]

connect-disconnect loop won't make a garbled console output. 

So set bug status to VERIFIED

Comment 8 errata-xmlrpc 2011-12-06 11:49:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1513.html


Note You need to log in before you can comment on or make changes to this bug.