Bug 7316 - netscape buttons not showing up right
Summary: netscape buttons not showing up right
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-25 03:49 UTC by Pat Gaddis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 20:55:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pat Gaddis 1999-11-25 03:49:21 UTC
recently, i had a RH 6.0 system with a MilleniumII video card.  I upgraded
the video card to a Voodoo3/3000 and used the then only available X server
(not even a part of XF86 at the time, i believe) for it.  Everything worked
great-- except for the tool buttons in Netscape.  They still show up, but
only as like black outlines.  My first thought was that Netscape just
couldn't allocate the colors, but X is running at 24bpp and everything else
always looks great, no matter how many different (color-intensive or not)
apps I run at a time.  Not long later, I formatted this machine and
installed RH 6.1.  This time, I obviously didn't have to go through any
trouble setting up the X server for the Voodoo3 because its now part of
XF86, yet I seem to be having the same exact problem as before.  On the RH
6.0 system, I was running NS 4.7 (tarball from netscape).  Even on the
fresh install of 6.1 (using NS 4.61), the same thing happened.  So because
Netscape is the only app that anything like this happens with, I'm inclined
to believe its a bug in Netscape.  However, recalling from experience,
problems like this usually lie in the app not being able to allocate the
colors it needs.  Any thoughts?

Comment 1 Preston Brown 2000-01-14 16:56:59 UTC
this is most probably a driver issue, not a netscape issue.  We'll try and check
it out before we release 6.2 to see if it has been fixed.

Comment 2 Preston Brown 2000-02-04 20:55:59 UTC
run at 32bpp, not 24bpp, and your problems will be fixed.


Note You need to log in before you can comment on or make changes to this bug.