Bug 731617 - update error: Protected multilib versions: gnome-panel-libs-3.0.2-4.fc16.x86_64 != gnome-panel-libs-3.0.2-3.fc16.i686
Summary: update error: Protected multilib versions: gnome-panel-libs-3.0.2-4.fc16.x86_...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 05:09 UTC by Joachim Backes
Modified: 2011-08-26 19:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-25 22:02:37 UTC


Attachments (Terms of Use)
scriptf file containing "sudo yum update" (39.20 KB, application/octet-stream)
2011-08-18 05:09 UTC, Joachim Backes
no flags Details
Script file: yum update --skip-broken --exclude=*.i686 (7.89 KB, text/plain)
2011-08-19 09:05 UTC, Joachim Backes
no flags Details
yum -d 4 --skip-broken update gnome-panel-libs (90.37 KB, text/plain)
2011-08-19 20:47 UTC, Andre Robatino
no flags Details
yum -d 4 --skip-broken update gnome-panel-libs (66.25 KB, text/plain)
2011-08-24 23:32 UTC, Andre Robatino
no flags Details

Description Joachim Backes 2011-08-18 05:09:43 UTC
Created attachment 518801 [details]
scriptf file containing "sudo yum update"

Description of problem:
Trying to update my current F16 fails: See attached script file!



Version-Release number of selected component (if applicable):
gnome-panel-libs-3.0.2-3.fc16.x86_64

How reproducible:
always

Steps to Reproduce:
1.sudo yum update
2.
3.
  
Actual results:
update error: Protected multilib versions: gnome-panel-libs-3.0.2-4.fc16.x86_64 != gnome-panel-libs-3.0.2-3.fc16.i686

Expected results:
performed update

Additional info:

Comment 1 Andre Robatino 2011-08-19 07:08:54 UTC
See this as well. I can work around it with

yum --skip-broken update --exclude=\*.i686

Comment 2 Joachim Backes 2011-08-19 08:10:40 UTC
(In reply to comment #1)
> See this as well. I can work around it with
> 
> yum --skip-broken update --exclude=\*.i686

I saw this already too. But there are still a lot packages which can't be updated:

Packages skipped because of dependency problems:
    empathy-3.1.5-1.fc16.x86_64 from updates-testing
    evolution-3.1.5-1.fc16.x86_64 from updates-testing
    evolution-NetworkManager-3.1.5-1.fc16.x86_64 from updates-testing
    evolution-data-server-3.1.5-1.fc16.x86_64 from updates-testing
    1:folks-0.6.0-2.fc16.x86_64 from updates-testing
    gnome-contacts-0.1.2-1.fc16.x86_64 from updates-testing
    gnome-panel-3.0.2-4.fc16.x86_64 from updates-testing
    gnome-panel-libs-3.0.2-4.fc16.x86_64 from updates-testing
    libsocialweb-0.25.19-1.fc16.x86_64 from fedora
    libsocialweb-keys-0.25.19-1.fc16.noarch from fedora
    1:nautilus-sendto-3.0.0-7.fc16.x86_64 from updates-testing

Comment 3 Joachim Backes 2011-08-19 09:05:48 UTC
Created attachment 518993 [details]
Script file: yum update --skip-broken --exclude=*.i686

Comment 4 Andre Robatino 2011-08-19 20:47:43 UTC
Created attachment 519103 [details]
yum -d 4 --skip-broken update gnome-panel-libs

Comment 5 Andre Robatino 2011-08-24 23:32:02 UTC
Created attachment 519742 [details]
yum -d 4 --skip-broken update gnome-panel-libs

Using the master mirror, still not working with the latest updates.

Comment 6 solanum 2011-08-25 14:41:33 UTC
out of the Update manager GUI, I'm getting something similar:

yum unspecified transaction errors:
evolution-3.1.4-1.fc16.x86_64 requires libebook-1.2.so.11()(64bit)
evolution-NetworkManager-3.1.4-1.fc16.x86_64 requires libedataserver-1.2.so.14()(64bit)
1:nautilus-sendto-3.0.0-6.fc16.x86_64 requires libedataserver-1.2.so.14()(64bit)
evolution-NetworkManager-3.1.4-1.fc16.x86_64 requires libecal-1.2.so.9()(64bit)
evolution-NetworkManager-3.1.4-1.fc16.x86_64 requires libebook-1.2.so.11()(64bit)
evolution-3.1.4-1.fc16.x86_64 requires libedataserver-1.2.so.14()(64bit)
1:nautilus-sendto-3.0.0-6.fc16.x86_64 requires libebook-1.2.so.11()(64bit)
evolution-3.1.4-1.fc16.x86_64 requires libecal-1.2.so.9()(64bit) : Protected multilib versions: gnome-panel-libs-3.0.2-3.fc16.i686 != gnome-panel-libs-3.1.5-3.fc16.x86_64

Comment 7 Matthias Clasen 2011-08-25 22:02:37 UTC
This is fixed in gnome-panel-3.1.5-3. You are now running into odd choices made by --skip-broken. Don't use it.

Comment 8 Andre Robatino 2011-08-25 22:09:40 UTC
Shouldn't this be closed as a duplicate of bug 728147? Currently, using --skip-broken is necessary in F16 due to a long list of other broken dependencies. (BTW, I could be wrong, as I don't see the problem in Rawhide, but it still sounds like a dupe.)

Comment 9 Andre Robatino 2011-08-25 23:12:43 UTC
For the sake of anyone still reading this bug,

yum update --skip-broken --exclude=gnome-panel,gnome-panel-libs

is a more precise workaround for people who have 32-bit packages already installed that also need updating.

Comment 10 Andre Robatino 2011-08-26 19:17:50 UTC
With today's 20110826 F16 updates, the problem is gone - "yum update --skip-broken" works. Probably some packages were changed/removed in the repos - there doesn't appear to be any change in bug 728147 that would account for it.


Note You need to log in before you can comment on or make changes to this bug.