Bug 731667 - GError: Failed to execute child process "/usr/sbin/ntpdate" (No such file or directory)
Summary: GError: Failed to execute child process "/usr/sbin/ntpdate" (No such file or ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-date
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:ffa7ae705a074bdf06d4f1e3905...
: 743420 744092 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 09:32 UTC by Jaroslav Škarvada
Modified: 2011-10-11 13:44 UTC (History)
5 users (show)

Fixed In Version: system-config-date-1.9.65-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-10-05 17:35:13 UTC


Attachments (Terms of Use)

Description Jaroslav Škarvada 2011-08-18 09:32:55 UTC
abrt version: 2.0.5
executable:     /usr/bin/python
hashmarkername: firstboot
kernel:         3.0.1-3.fc16.x86_64
reason:         GError: Failed to execute child process "/usr/sbin/ntpdate" (No such file or directory)
time:           Thu Aug 18 11:32:10 2011

description:
:The following was filed automatically by firstboot:
:firstboot 16.1 exception report
:Traceback (most recent call last):
:  File "/usr/share/system-config-date/date_gui.py", line 396, in cell_edited
:    if self.ntpSrvValidAdd (new_text) and self.ntpSrvReachable (new_text):
:  File "/usr/share/system-config-date/date_gui.py", line 312, in ntpSrvReachable
:    (pid, stdin, stdout, stderr) = gobject.spawn_async (argv, flags = gobject.SPAWN_STDOUT_TO_DEV_NULL | gobject.SPAWN_STDERR_TO_DEV_NULL  | gobject.SPAWN_DO_NOT_REAP_CHILD)
:GError: Failed to execute child process "/usr/sbin/ntpdate" (No such file or directory)

firstboot-tb-4eFXYd:
:firstboot 16.1 exception report
:Traceback (most recent call last):
:  File "/usr/share/system-config-date/date_gui.py", line 396, in cell_edited
:    if self.ntpSrvValidAdd (new_text) and self.ntpSrvReachable (new_text):
:  File "/usr/share/system-config-date/date_gui.py", line 312, in ntpSrvReachable
:    (pid, stdin, stdout, stderr) = gobject.spawn_async (argv, flags = gobject.SPAWN_STDOUT_TO_DEV_NULL | gobject.SPAWN_STDERR_TO_DEV_NULL  | gobject.SPAWN_DO_NOT_REAP_CHILD)
:GError: Failed to execute child process "/usr/sbin/ntpdate" (No such file or directory)
:
:Local variables in innermost frame:
:host: clock.redhat.com
:self: <date_gui.datePage object at 0x1d9b850>
:argv: ['/usr/sbin/ntpdate', '-d', 'clock.redhat.com']
:
:
:Config instance, containing members:
:frontend: Frontend instance, containing members:
:  frontend.wm_pid: 882
:  frontend.x: Popen instance, containing members:
:    frontend.x._child_created: True
:    frontend.x.returncode: None
:    frontend.x.stdout: None
:    frontend.x.stdin: None
:    frontend.x.pid: 805
:    frontend.x.stderr: None
:    frontend.x.universal_newlines: False
:moduleDir: None
:needInterface: False
:themeDir: /usr/share/firstboot/themes/fedora-lovelock
:mode: 1
:interface: Interface instance, containing members:
:  interface.backButton: Button instance, containing members:
:  interface.buttonBox: HButtonBox instance, containing members:
:  interface._screenshotDir: /root/firstboot-screenshots
:  interface.win: Window instance, containing members:
:  interface._control: Control instance, containing members:
:    interface._control.currentPage: 2
:    interface._control.moduleList: [moduleClass instance, containing members:
:      title: Welcome
:      sidebarTitle: Welcome
:      priority: 1
:      vbox: VBox instance, containing members:
:      mode: 1
:      icon: workstation.png
:, moduleClass instance, containing members:
:      title: License Information
:      sidebarTitle: License Information
:      priority: 2
:      vbox: VBox instance, containing members:
:      mode: 1
:      icon: workstation.png
:, moduleClass instance, containing members:
:      title: Date and Time
:      scd: scdMainWindow instance, containing members:
:        scd.custom_handler_modules: [<module 'date_gui' from '/usr/share/system-config-date/date_gui.pyc'>
:, <module 'timezone_gui' from '/usr/share/system-config-date/timezone_gui.pyc'>
:]
:        scd.xml: XML instance, containing members:
:        scd.allPages: [datetime, timezone]
:        scd.timezoneBackend: timezoneBackend instance, containing members:
:          scd.timezoneBackend.utc: true
:          scd.timezoneBackend.tz: Europe/Prague
:          scd.timezoneBackend._adjtimeHasUTCInfo: True
:          scd.timezoneBackend._canHwClock: True
:        scd.win: Window instance, containing members:
:        scd.nb: Notebook instance, containing members:
:        scd.datePage: datePage instance, containing members:
:          scd.datePage.ntpSrvButtonbox: VButtonBox instance, containing members:
:          scd.datePage.ntpIburstButton: CheckButton instance, containing members:
:          scd.datePage.ntpLocalTimeSource: False
:          scd.datePage.ntpBroadcastClientCheckButton: CheckButton instance, containing members:
:          scd.datePage.ntpServers: [0.fedora.pool.ntp.org, 1.fedora.pool.ntp.org, 2.fedora.pool.ntp.org, 3.fedora.pool.ntp.org]
:          scd.datePage.dateTimeLabel: Label instance, containing members:
:          scd.datePage.ntpLabel: Label instance, containing members:
:          scd.datePage.ntpAdvOptionsExpanderLabel: Label instance, containing members:
:          scd.datePage.ntpAdvOptionsExpander: Expander instance, containing members:
:          scd.datePage.cellrend: CellRendererText instance, containing members:
:          scd.datePage.xml: Already dumped (XML instance)
:          scd.datePage.NTPSERVER: 0
:          scd.datePage.ntpServersTreeView: TreeView instance, containing members:
:          scd.datePage.ntpFrame: None
:          scd.datePage.ntpSrvEditButton: Button instance, containing members:
:          scd.datePage.ntpCheckButton: CheckButton instance, containing members:
:          scd.datePage.hourEntry: SpinButton instance, containing members:
:          scd.datePage.ntpSrvAddButton: Button instance, containing members:
:          scd.datePage.manualNtpNotebook: Notebook instance, containing members:
:          scd.datePage.minEntry: SpinButton instance, containing members:
:          scd.datePage.flag: False
:          scd.datePage.added_row_reference: TreeRowReference instance, containing members:
:
:Exception occurred during state dump:
:Traceback (most recent call last):
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 231, in dump
:    self._dumpClass(obj, fd, skipList=idSkipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 185, in _dumpClass
:    self._dumpClass(value, fd, level + 1, parentkey=curkey, skipList=skipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 185, in _dumpClass
:    self._dumpClass(value, fd, level + 1, parentkey=curkey, skipList=skipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 161, in _dumpClass
:    self._dumpClass(item, fd, level + 1, skipList=skipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 185, in _dumpClass
:    self._dumpClass(value, fd, level + 1, parentkey=curkey, skipList=skipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 185, in _dumpClass
:    self._dumpClass(value, fd, level + 1, parentkey=curkey, skipList=skipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 185, in _dumpClass
:    self._dumpClass(value, fd, level + 1, parentkey=curkey, skipList=skipList)
:  File "/usr/lib/python2.7/site-packages/meh/dump.py", line 133, in _dumpClass
:    for key, value in instance.__dict__.items():
:AttributeError: 'gtk.TreeRowReference' object has no attribute '__dict__'

Comment 1 Nils Philippsen 2011-08-19 09:37:35 UTC
I guess this is related to the fix of bug #616385: This adds support for chrony and in the course removed s-c-date's dependency on the ntp package. Unfortunately, s-c-date code still assumes some things to just "be there", I'll add code to better cope with stuff like ntpdate etc. missing.

Comment 2 Fedora Update System 2011-08-19 15:27:23 UTC
system-config-date-1.9.63-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/system-config-date-1.9.63-1.fc16

Comment 3 Fedora Update System 2011-08-22 18:33:54 UTC
Package system-config-date-1.9.63-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-date-1.9.63-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-date-1.9.63-1.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2011-08-23 20:26:19 UTC
Package system-config-date-1.9.64-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-date-1.9.64-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-date-1.9.64-1.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2011-09-10 18:56:33 UTC
Package system-config-date-1.9.65-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-date-1.9.65-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/system-config-date-1.9.65-1.fc16
then log in and leave karma (feedback).

Comment 6 Nils Philippsen 2011-10-05 09:23:06 UTC
*** Bug 743420 has been marked as a duplicate of this bug. ***

Comment 7 Fedora Update System 2011-10-05 17:35:08 UTC
system-config-date-1.9.65-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Nils Philippsen 2011-10-11 13:44:42 UTC
*** Bug 744092 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.