Bug 731669 - [boinc-manager] menu bar almost not displayed
Summary: [boinc-manager] menu bar almost not displayed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: boinc-client
Version: 14
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milos Jakubicek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 719876 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 09:42 UTC by Vratislav Podzimek
Modified: 2012-07-13 07:14 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-11 23:56:08 UTC


Attachments (Terms of Use)
screenshot of boinc-manager's window (77.51 KB, image/png)
2011-08-18 09:42 UTC, Vratislav Podzimek
no flags Details

Description Vratislav Podzimek 2011-08-18 09:42:17 UTC
Created attachment 518834 [details]
screenshot of boinc-manager's window

Description of problem:
boinc-manager's menu bar is displayed in a *very* poor way (screenshot attached)

Version-Release number of selected component (if applicable):
Version     : 6.10.58
Release     : 3.r22930svn.fc14

How reproducible:
100%

Steps to Reproduce:
1. run boinc-manager
2. see the menu bar
  
Actual results:
menu bar is displayed incorrectly (almost not)

Expected results:
menu bar is displayed correctly

Additional info:
Sorry for bad component, I wasn't able to find boinc-manager in the list. 
I've tried some other wxGTK-based apps and they run without any problems.

Comment 1 Milos Jakubicek 2011-08-19 20:09:06 UTC
*** Bug 719876 has been marked as a duplicate of this bug. ***

Comment 2 Milos Jakubicek 2011-08-19 20:17:10 UTC
Confirming, filed upstream at http://boinc.berkeley.edu/trac/ticket/1130

Comment 3 Vratislav Podzimek 2011-08-29 11:25:27 UTC
There is a simple workaround -- if you resize the window, whole menu bar appears.

Comment 4 Juan Orti Alcaine 2011-11-29 17:27:31 UTC
Same problem here. Fedora 16 x86_64
boinc-manager-6.10.58-3.r22930svn.fc15.x86_64

Comment 5 Germano Massullo 2012-02-24 17:15:55 UTC
Should not we close this bugreport as UPSTREAM?

Comment 6 Germano Massullo 2012-04-25 10:30:49 UTC
Any news?

Comment 7 Germano Massullo 2012-05-26 17:04:30 UTC
ping?

Comment 8 Robert Kief 2012-07-05 03:39:53 UTC
I have this bug also.  It was present in Fedora 16 and is also present in Fedora 17.  As the reporter indicated, resizing the BOINC Manager window returns the complete menu bar to view.

Comment 9 Sven Lankes 2012-07-09 09:42:10 UTC
@milos - there seems to be a fix upstream: 

http://boinc.berkeley.edu/trac/changeset?reponame=boinc&new=25702%40trunk&old=25701%40trunk

could you patch the fedora package to include that fix?

-- 
sven

Comment 10 Milos Jakubicek 2012-07-09 12:12:11 UTC
I already did that -- there is a scratch build available in Koji, I will submit it as an update soon (hopefully today).

Comment 11 Fedora Update System 2012-07-10 07:28:45 UTC
boinc-client-7.0.29-1.r25790svn.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-9859/boinc-client-7.0.29-1.r25790svn.fc17

Comment 12 Fedora Update System 2012-07-11 23:56:08 UTC
boinc-client-7.0.29-1.r25790svn.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Vratislav Podzimek 2012-07-13 07:14:54 UTC
(In reply to comment #12)
> boinc-client-7.0.29-1.r25790svn.fc17 has been pushed to the Fedora 17 stable
> repository.  If problems still persist, please make note of it in this bug
> report.
I can confirm that the new build resolves this bug. Thanks for fixing.


Note You need to log in before you can comment on or make changes to this bug.