Bug 731767 - grub2 spec requires /usr/lib/crt1.o on .el6 while it is in /usr/lib64/crt1.o
Summary: grub2 spec requires /usr/lib/crt1.o on .el6 while it is in /usr/lib64/crt1.o
Keywords:
Status: CLOSED DUPLICATE of bug 825322
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: grub2
Version: el6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 15:08 UTC by David Jaša
Modified: 2012-05-25 17:25 UTC (History)
2 users (show)

Fixed In Version: 1.99-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-25 17:25:38 UTC


Attachments (Terms of Use)

Description David Jaša 2011-08-18 15:08:04 UTC
Description of problem:
SSIA

Version-Release number of selected component (if applicable):
grub2-1:1.99-0.2

How reproducible:
always

Steps to Reproduce:
1. install all build dependencies of grub2
2. run rpmbuild --rebuild $grub2_srpm
3.
  
Actual results:
build fails with:
error: Failed build dependencies:
	/usr/lib/crt1.o is needed by grub2-1:1.99-0.2.el6_1.x86_64

Expected results:
grub2 packages builds cleanly

Additional info:
If I change this part of grub2.spec:

%ifarch %{sparc}
BuildRequires:  /usr/lib64/crt1.o glibc-static
%else
BuildRequires:  /usr/lib/crt1.o glibc-static
%endif

to just:

BuildRequires:  /usr/lib64/crt1.o glibc-static

grub2 builds cleanly, so probably there should be added some other condition for el6 builds.

Comment 1 Mads Kiilerich 2011-09-06 20:27:13 UTC
This has been fixed in Fedora 16 grub2-1.99-5.

Comment 2 David Jaša 2011-09-13 09:15:10 UTC
It was actually fixed in 1.99-1: 
http://pkgs.fedoraproject.org/gitweb/?p=grub2.git;a=commitdiff;h=ee1d6dae6fd2ceb06416836f6011b69840e0ff53#patch4

-%ifarch %{sparc}
+%ifarch %{sparc} x86_64
 BuildRequires:  /usr/lib64/crt1.o glibc-static
 %else
 BuildRequires:  /usr/lib/crt1.o glibc-static

Comment 3 Mads Kiilerich 2012-05-25 17:25:38 UTC
Actually not - that fix was incorrect.

*** This bug has been marked as a duplicate of bug 825322 ***


Note You need to log in before you can comment on or make changes to this bug.