Bug 731810 - Deleteing a provider renders an server side error
Summary: Deleteing a provider renders an server side error
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: API
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-18 18:42 UTC by Bryan Kearney
Modified: 2015-01-04 21:58 UTC (History)
2 users (show)

Fixed In Version: katello-0.1.65-1~2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:09 UTC


Attachments (Terms of Use)

Description Bryan Kearney 2011-08-18 18:42:58 UTC
From a clean install, exeute these commands:

provider create --org ACME_Corporation --name katello --type custom
provider delete --org ACME_Corporation --name katello


you will get back the following error client side, and in the katello.log file

error: operation failed: undefined method `to_sym' for nil:NilClass


Versions:
katello-0.1.64-1.git.0.0b431ff.fc15.noarch
katello-cli-0.1.4-1.git.63.54683c2.fc15.noarch

Comment 1 Ivan Necas 2011-08-19 07:09:24 UTC
Fixed in commit 82404fd22e971.

Related to bug https://bugzilla.redhat.com/show_bug.cgi?id=727627 (the same type of error)

Caused by incompatibility of Rails with fast_gettext - https://github.com/grosser/fast_gettext/issues/23

Comment 2 Garik Khachikyan 2011-09-23 14:14:08 UTC
# VERIFIED

The issue is fixed now.

repeat of the scenario in bug description brings to:
---
Deleted provider [ katello ]
---

And the provider really gets removed (provider list --org ACME_Corporation)

Checked against: 
katello-cli-0.1.10-1.git.278.85760dc.el6.noarch
katello-0.1.83-1.git.48.02111ba.fc15.noarch

Comment 5 Mike McCune 2013-08-16 18:05:41 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.