Bug 731815 - libnih and yum do not like each other anymore
Summary: libnih and yum do not like each other anymore
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libnih
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 743996 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 18:52 UTC by Michal Jaegermann
Modified: 2011-11-19 06:03 UTC (History)
5 users (show)

Fixed In Version: libnih-1.0.2-5.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-19 06:03:14 UTC


Attachments (Terms of Use)

Description Michal Jaegermann 2011-08-18 18:52:14 UTC
Description of problem:

With the current rawhide an attempt 'yum install libnih.x86_64' ends up with:

Downloading Packages:
libnih-1.0.2-4.fc15.x86_64.rpm                              | 137 kB     00:00     
Running Transaction Check
ERROR with transaction check vs depsolve:
libc.so.6(GLIBC_PRIVATE)(64bit) is needed by libnih-1.0.2-4.fc15.x86_64
Please report this error in http://yum.baseurl.org/report

That does not look like a yum error as
'rpm -i --test libnih-1.0.2-4.fc15.x86_64.rpm' reports too:

error: Failed dependencies:
        libc.so.6(GLIBC_PRIVATE)(64bit) is needed by libnih-1.0.2-4.fc15.x86_64

By the same token a presence of libnih blocks attempts to update to
glibc-2.14.90-5 packages while this was not a problem with glibc-2.14.90-4.
OTOH 'rawhide report: 20110818 changes' does not seem to list any relevant broken dependencies.

Version-Release number of selected component (if applicable):
libnih-1.0.2-4.fc15
glibc-2.14.90-5

Additional information:
Maybe yum should really notice in the earlier stage that a transaction will fail?  I really cannot tell what glibc _should_ provide.

Comment 1 Casey Dahlin 2011-08-18 18:57:52 UTC
libnih probably needs a rebuild. In fact it hasn't even been rebased in awhile since its only user was Upstart, which systemd replaced. I'll move it ahead.

Comment 2 Michal Jaegermann 2011-08-18 19:08:43 UTC
(In reply to comment #1)
> libnih probably needs a rebuild. In fact it hasn't even been rebased in awhile
> since its only user was Upstart, which systemd replaced. I'll move it ahead.

If there are no users then maybe it is not needed anymore?

I was rather scratching my head why apparently nothing reported broken dependencies in advance.

Comment 3 Casey Dahlin 2011-08-18 19:11:40 UTC
Petr was maintaining upstart as an ongoing curiosity. I'm not sure if he stopped.

Comment 4 collura 2011-09-10 00:58:49 UTC
just noticed this when was running updates with 'software management' interface on f15 kde machine and got the following message when tried updates of glibc:

   'libnih-1.0.2-4.fc15.x86_64 requires libc.so.6(GLIBC_PRIVATE)(64bit) : Success - empty transaction'

Comment 5 collura 2011-09-10 02:35:51 UTC
hmm the glibc updates just installed on a f15-gnome machine and had no problem...

lol, kde strikes again

Comment 6 Edward Sheldrake 2011-09-11 08:46:49 UTC
libnih.spec (and nss_db.spec and any others) set _filter_GLIBC_PRIVATE - but they should set __filter_GLIBC_PRIVATE to filter out the GLIBC_PRIVATE dependencies.

Comment 7 Petr Lautrbach 2011-11-07 14:30:36 UTC
*** Bug 743996 has been marked as a duplicate of this bug. ***

Comment 8 Fedora Update System 2011-11-07 15:05:55 UTC
libnih-1.0.2-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libnih-1.0.2-5.fc16

Comment 9 Fedora Update System 2011-11-10 17:27:12 UTC
Package libnih-1.0.2-5.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libnih-1.0.2-5.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15575
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2011-11-19 06:03:14 UTC
libnih-1.0.2-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.