Bug 731843 - F15/F14 contains duplicates in GA repo.
Summary: F15/F14 contains duplicates in GA repo.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Bill Nottingham
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 19:47 UTC by James Antill
Modified: 2014-03-17 03:28 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-18 21:54:34 UTC


Attachments (Terms of Use)

Description James Antill 2011-08-18 19:47:29 UTC
Description of problem:

 Not sure if this is known about already, but I didn't know about it and I've got commands so you can see it easily.

% repoquery -a --repoid=fedora --show-dupes | wc -l
24085
% repoquery -a --repoid=fedora | wc -l
24057

 If you diff the output, you see a few entries where we have multiple versions of a single package:

Available Packages
ruby-sqlite3.x86_64                 1.2.4-6.fc15                     fedora 
ruby-sqlite3.x86_64                 1.3.3-3.fc15                     fedora 
ruby-vte.x86_64                     0.90.4-1.3.fc15                  fedora 
ruby-vte.x86_64                     0.90.8-2.fc15                    fedora 

 I checked F14, and that also had some ... didn't check further back.

Comment 1 Dennis Gilmore 2011-08-18 21:54:34 UTC
[ausil@releng02 ~]$ rpm -qp --qf "%{SOURCERPM}\n" /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte*
advertencia:/pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte-0.90.4-1.3.fc15.x86_64.rpm: CabeceraV3 RSA/SHA256 signature: NOKEY, key ID 069c8460
ruby-gnome2-0.90.4-1.3.fc15.src.rpm
rubygem-vte-0.90.8-2.fc15.src.rpm
ruby-gnome2-0.90.4-1.3.fc15.src.rpm
ruby-gnome2-0.90.4-1.3.fc15.src.rpm
[ausil@releng02 ~]$ ls /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte*
/pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte-0.90.4-1.3.fc15.x86_64.rpm  /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte-devel-0.90.4-1.3.fc15.i686.rpm
/pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte-0.90.8-2.fc15.x86_64.rpm    /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-vte-devel-0.90.4-1.3.fc15.x86_64.rpm

2 different packages produce a ruby-vte binary rpm


[ausil@releng02 ~]$ ls /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-sqlite*
/pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-sqlite3-1.2.4-6.fc15.x86_64.rpm  /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-sqlite3-1.3.3-3.fc15.x86_64.rpm
[ausil@releng02 ~]$ rpm -qp --qf "%{SOURCERPM}\n" /pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-sqlite*
advertencia:/pub/fedora/linux/releases/15/Everything/x86_64/os/Packages/ruby-sqlite3-1.2.4-6.fc15.x86_64.rpm: CabeceraV3 RSA/SHA256 signature: NOKEY, key ID 069c8460
rubygem-sqlite3-ruby-1.2.4-6.fc15.src.rpm
rubygem-sqlite3-1.3.3-3.fc15.src.rpm


same for ruby-sqlite3.  there is nothing we can do to keep them out, we cant retroactively go back and fix it either. 


its quite possible that one package was supposed to be removed

Comment 2 James Antill 2011-08-19 13:23:58 UTC
 Yeh, there was just a lot so I figured it couldn't all be package moves ... but a bunch of stuff moved from perl into modules. Oh well.
 Is it worth running a script to remind people to deprecate old packages?


Note You need to log in before you can comment on or make changes to this bug.