Bug 731863 - aeolus-cleanup cleans up everything, should be more selective
Summary: aeolus-cleanup cleans up everything, should be more selective
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: CloudForms Cloud Engine
Classification: Retired
Component: aeolus-configure
Version: 1.0.0
Hardware: All
OS: All
medium
high
Target Milestone: rc
Assignee: Richard Su
QA Contact: Dave Johnson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-18 20:11 UTC by Marcelo Giles
Modified: 2018-11-28 21:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-15 20:38:49 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0586 normal SHIPPED_LIVE new packages: aeolus-configure 2012-05-15 22:31:34 UTC

Description Marcelo Giles 2011-08-18 20:11:28 UTC
Description of problem:
Currently, aeolus-cleanup cleans up all settings and restarts many of the sub components. It would be desirable to have something like aeolus-cleanup --component so it only acts on relevant settings that need fixing while leaving the ones that are working intact.

For a similar example, check out the new rhevm 3.0 configuration tool, rhevm-setup, that has options for different components. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 William Henry 2011-08-18 20:16:28 UTC
One suggestion is that you might want to cleanup all the tools but you may wish to keep images you have created. I.e. cleanup everything except all the images I built.

Comment 2 Matt Wagner 2011-08-18 20:19:58 UTC
Updating component: this is a component of aeolus-configure, not something related to user accounts.

Comment 3 wes hayutin 2011-09-28 16:40:38 UTC
making sure all the bugs are at the right version for future queries

Comment 5 Richard Su 2011-12-08 23:11:48 UTC
Here is how I'm thinking of approaching this. There are two parts:

(1) a command line option to cleanup but not destroy any data
(2) new options to selectively cleanup specific components

For two, I'll plan to implement the following options

aeolus-cleanup -p iwhd
aeolus-cleanup -p imagefactory
aeolus-cleanup -p deltacloud
aeolus-cleanup -p conductor
aeolus-cleanup -p rhevm (its only action will be to unmount the rhevm export directory)

There won't be a -p option for ec2 or vsphere because their configure profiles are just supersets of the above.

Marcelo, let me know if this doesn't mesh with what you had in mind or if there are other scenarios to be considered.

Thanks.

Comment 6 Richard Su 2011-12-17 00:51:03 UTC
Changes in configure commits:
3d8c09b5d4c8a24c0b8ab26df6c3b64ef126d8d4
87b94021a70d68a1134213b293598d3a096dea60

Comment 7 Richard Su 2011-12-21 00:19:39 UTC
Changes available in aeolus-configure.noarch 0:2.5.0-0.20111220094137git3d8c09b

Comment 9 Shveta 2012-02-10 07:34:53 UTC
aeolus-cleanup -p iwhd
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Exec[clean_iwhd]/returns: Objects deleted: 0
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Exec[clean_iwhd]/returns: executed successfully
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[iwhd]/ensure: ensure changed 'running' to 'stopped'
notice: /File[/var/lib/iwhd]/ensure: removed
notice: /Stage[main]/Aeolus::Iwhd::Disabled/Service[mongod]/ensure: ensure changed 'running' to 'stopped'
notice: Finished catalog run in 1.95 seconds

[root@qe-blade-08 ~]# service iwhd status
iwhd is stopped
==========================================================================
 aeolus-cleanup -p imagefactory
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Service[imagefactory]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Service[qpidd]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Image-factory::Disabled/Exec[remove_aeolus_templates]/returns: executed successfully
notice: Finished catalog run in 0.78 seconds

[root@qe-blade-08 ~]# service imagefactory status
imagefactory is stopped
==============================================================================
aeolus-cleanup -p deltacloud
notice: /Stage[main]/Aeolus::Deltacloud::Disabled/Service[deltacloud-core]/ensure: ensure changed 'running' to 'stopped'
notice: Finished catalog run in 0.31 seconds
[root@qe-blade-08 ~]# service deltacloud status
deltacloud: unrecognized service

[root@qe-blade-08 ~]# service deltacloud-core status
deltacloud-core is stopped
==================================================================

aeolus-cleanup -p conductor
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[conductor-dbomatic]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[aeolus-conductor]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Conductor::Disabled/Service[httpd]/ensure: ensure changed 'running' to 'stopped'
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: Using gem require instead of bundler
notice: /Stage[main]/Aeolus::Conductor::Disabled/Rails::Drop::Db[drop_aeolus_database]/Exec[drop_rails_database]/returns: executed successfully
notice: /Stage[main]/Aeolus::Conductor::Disabled/Postgres::User[aeolus]/Exec[drop_aeolus_postgres_user]/returns: executed successfully
notice: /File[/etc/rsyslog.d/aeolus.conf]/ensure: removed
notice: /File[/var/lib/aeolus-conductor]/ensure: removed
notice: Finished catalog run in 3.83 seconds

[root@qe-blade-08 ~]# service aeolus-conductor status
thin is stopped

=========================================================================
aeolus-cleanup -p rhevm
notice: Finished catalog run in 0.15 seconds

verified w/
rpm -qa|grep aeolus
aeolus-conductor-doc-0.8.0-25.el6.noarch
aeolus-conductor-daemons-0.8.0-25.el6.noarch
aeolus-configure-2.5.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-8.el6.noarch
rubygem-aeolus-image-0.3.0-7.el6.noarch
aeolus-all-0.8.0-25.el6.noarch
aeolus-conductor-0.8.0-25.el6.noarch

Comment 10 errata-xmlrpc 2012-05-15 20:38:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0586.html


Note You need to log in before you can comment on or make changes to this bug.