Bug 731910 - Turn off input method: r-click or shortcut Ctrl+Space, does not work anymore
Turn off input method: r-click or shortcut Ctrl+Space, does not work anymore
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Mac OS
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
: Reopened
: 734046 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-08-18 22:29 EDT by nomnex
Modified: 2011-08-30 21:29 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110419-18.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-30 21:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description nomnex 2011-08-18 22:29:13 EDT
Description of problem:

I guess there's been 2 updates. Prior the updates, turning off input method with a right click of shortuct Ctrl+Space was working. It's not working anymore. 

Version-Release number of selected component (if applicable):

IBus 1.3.99.20110814

How reproducible:

always, with any input language (JP, CA, CH)


Steps to Reproduce:
1. Select an input language (a different input language need to be selected the first time)
2. Turn off input language
3. Click on a new field in a web page or open a new document
  
Actual results:

Ibus pops-up with the last used input language. Turn if off again, and click on a different field, ibus pops-up again.

Expected results:

It looks like I can't turn off ibus anymore (only in the active document of the field).

Additional info:

I am not sure if it is a regression, a new setting (change), and if I am the only one affected by this problem?

Anytime I want to to turn off ibu, I have to use the re-start option.
Comment 1 nomnex 2011-08-18 22:49:30 EDT
Regenerating /home/mt/.cache/ibus/bus/registry.xml file did not help.

My setting is:

ibus preferences> advanced > global input method settings

Share the same input methode among all applications [ON]

Using the same setting, 2 updates ago, I could turn ibus ON-OFF and it was steady. It is broken for me now (ibus keeps re-enabling itself).

If I change the preferences:

Share the same input method among all applications [OFF]

Then, turning ibus ON-OFF is steady.
Comment 2 fujiwara 2011-08-18 22:57:57 EDT

*** This bug has been marked as a duplicate of bug 731610 ***
Comment 3 Fedora Update System 2011-08-19 04:10:54 EDT
ibus-1.3.99.20110419-17.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-17.fc15
Comment 4 Fedora Update System 2011-08-19 04:12:01 EDT
ibus-1.3.99.20110419-17.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-17.fc16
Comment 5 Fedora Update System 2011-08-19 17:59:50 EDT
Package ibus-1.3.99.20110419-17.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-17.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-17.fc15
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-08-28 01:41:10 EDT
ibus-1.3.99.20110419-18.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 fujiwara 2011-08-29 20:47:28 EDT
*** Bug 734046 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2011-08-30 21:29:17 EDT
ibus-1.3.99.20110419-18.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.