Bug 731949 - btrfs kernel BUG at fs/btrfs/inode.c:2920
Summary: btrfs kernel BUG at fs/btrfs/inode.c:2920
Keywords:
Status: CLOSED DUPLICATE of bug 698324
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Josef Bacik
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 08:29 UTC by Eryu Guan
Modified: 2012-06-07 14:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-07 14:23:21 UTC


Attachments (Terms of Use)

Description Eryu Guan 2011-08-19 08:29:24 UTC
Description of problem:
This panic happened during beaker distribution install and happened only once

btrfs failed to delete reference to tmp.rhts-db-submit-result._Hi6ns, inode 266 parent 256 
------------[ cut here ]------------ 
kernel BUG at fs/btrfs/inode.c:2920! 
invalid opcode: 0000 [#1] SMP  
last sysfs file: /sys/devices/pci0000:00/0000:00:01.1/host0/target0:0:0/0:0:0:0/block/sda/size 
CPU 0  
Modules linked in: sunrpc ipv6 btrfs(T) zlib_deflate lzo_decompress lzo_compress libcrc32c microcode virtio_balloon virtio_net i2c_piix4 i2c_core sg ext3 jbd mbcache sd_mod crc_t10dif virtio_pci virtio_ring virtio pata_acpi ata_generic ata_piix dm_mirror dm_region_hash dm_log dm_mod [last unloaded: speedstep_lib] 
 
Pid: 1864, comm: rhts-db-submit- Tainted: G           ---------------- T 2.6.32-188.el6.x86_64 #1 Red Hat KVM 
RIP: 0010:[<ffffffffa019bde3>]  [<ffffffffa019bde3>] btrfs_unlink+0x113/0x130 [btrfs] 
RSP: 0018:ffff88007d159e38  EFLAGS: 00010282 
RAX: 00000000fffffffe RBX: ffff88007bea94e0 RCX: 0000000000000000 
RDX: 000000000000000f RSI: ffff88007bea8910 RDI: 0000000000000286 
RBP: ffff88007d159e68 R08: ffffffff81c00500 R09: 0000000000000000 
R10: 0000000000000000 R11: 6572656665722065 R12: 00000000fffffffe 
R13: ffff88007e3979a8 R14: ffff88007d115000 R15: ffff88007bf2ad90 
FS:  00007f12cc721700(0000) GS:ffff880002200000(0000) knlGS:0000000000000000 
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033 
CR2: 00007fb0a257d000 CR3: 000000007ad82000 CR4: 00000000000006f0 
DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000 
DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400 
Process rhts-db-submit- (pid: 1864, threadinfo ffff88007d158000, task ffff8800377f54c0) 
Stack: 
 0000000000000000 ffff88007bef9bc0 ffff88007e3979a8 ffff88007bf2ad90 
<0> 0000000000000000 00000000ffffffff ffff88007d159e98 ffffffff81183580 
<0> ffff88007d159e98 ffffffff811851ea ffff88007d159ea8 ffff88007bef9bc0 
Call Trace: 
 [<ffffffff81183580>] vfs_unlink+0xa0/0xf0 
 [<ffffffff811851ea>] ? lookup_hash+0x3a/0x50 
 [<ffffffff81186b03>] do_unlinkat+0x183/0x1c0 
 [<ffffffff810d43d2>] ? audit_syscall_entry+0x272/0x2a0 
 [<ffffffff81186b56>] sys_unlink+0x16/0x20 
 [<ffffffff8100b0b2>] system_call_fastpath+0x16/0x1b 
Code: 85 c9 74 36 c7 80 44 22 00 00 00 00 00 00 eb b1 0f 1f 84 00 00 00 00 00 4c 89 fe 48 89 df e8 65 cc ff ff 85 c0 74 82 0f 0b eb fe <0f> 0b eb fe 41 89 c4 66 0f 1f 44 00 00 eb 9d 0f 0b eb fe 66 2e  
RIP  [<ffffffffa019bde3>] btrfs_unlink+0x113/0x130 [btrfs] 
 RSP <ffff88007d159e38> 
---[ end trace c3f7f648cd3deca4 ]--- 
Kernel panic - not syncing: Fatal exception 
Pid: 1864, comm: rhts-db-submit- Tainted: G      D    ---------------- T 2.6.32-188.el6.x86_64 #1 
Call Trace: 
 [<ffffffff814ea395>] ? panic+0x78/0x143 
 [<ffffffff814ee534>] ? oops_end+0xe4/0x100 
 [<ffffffff8100f22b>] ? die+0x5b/0x90 
 [<ffffffff814ede04>] ? do_trap+0xc4/0x160 
 [<ffffffff8100cdf5>] ? do_invalid_op+0x95/0xb0 
 [<ffffffffa019bde3>] ? btrfs_unlink+0x113/0x130 [btrfs] 
 [<ffffffff814ea4a1>] ? printk+0x41/0x48 
 [<ffffffff8100be9b>] ? invalid_op+0x1b/0x20 
 [<ffffffffa019bde3>] ? btrfs_unlink+0x113/0x130 [btrfs] 
 [<ffffffffa019bd4d>] ? btrfs_unlink+0x7d/0x130 [btrfs] 
 [<ffffffff81183580>] ? vfs_unlink+0xa0/0xf0 
 [<ffffffff811851ea>] ? lookup_hash+0x3a/0x50 
 [<ffffffff81186b03>] ? do_unlinkat+0x183/0x1c0 
 [<ffffffff810d43d2>] ? audit_syscall_entry+0x272/0x2a0 
 [<ffffffff81186b56>] ? sys_unlink+0x16/0x20 
 [<ffffffff8100b0b2>] ? system_call_fastpath+0x16/0x1b 

Version-Release number of selected component (if applicable):
kernel-2.6.32-188.el6

How reproducible:
Unknown

Steps to Reproduce:
1.Unknown, maybe install distribution in beaker with one btrfs partition mounted at /mnt/testarea
2.
3.
  
Actual results:
panic

Expected results:
No panic

Additional info:
Beaker job:
https://beaker.engineering.redhat.com/jobs/121868
Log:
http://lab2.rhts.eng.bos.redhat.com/beaker/logs/recipes/250721//console.log

Comment 3 RHEL Product and Program Management 2011-10-07 15:45:22 UTC
Since RHEL 6.2 External Beta has begun, and this bug remains
unresolved, it has been rejected as it is not proposed as
exception or blocker.

Red Hat invites you to ask your support representative to
propose this request, if appropriate and relevant, in the
next release of Red Hat Enterprise Linux.

Comment 5 Josef Bacik 2011-10-10 13:43:38 UTC
Can you clone my git tree

git://git.engineering.redhat.com/users/jwhiter/rhel6.git btrfs-fixes

I've just done a big backport and hopefully have fixed this in the process.

Comment 6 Josef Bacik 2012-06-07 14:23:21 UTC

*** This bug has been marked as a duplicate of bug 698324 ***


Note You need to log in before you can comment on or make changes to this bug.