Bug 731964 - Cannot upgrade with /usr/local/src nfs mounted
Summary: Cannot upgrade with /usr/local/src nfs mounted
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: filesystem
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 09:47 UTC by Mark Wielaard
Modified: 2011-09-06 09:28 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-19 10:32:47 UTC


Attachments (Terms of Use)

Description Mark Wielaard 2011-08-19 09:47:37 UTC
Description of problem:

When you have anything mounted on /usr/local/src a filesytem upgrade fails.
/usr/local/src is nfs mounted to make all local sources available to all machines. Is this a supported setup?

Version-Release number of selected component (if applicable):

filesystem-2.4.44-2.fc17.x86_64

How reproducible:

Always (if something mounted on /usr/local/src)

Steps to Reproduce:
1. nfs mount something on /usr/local/src
2. yum upgrade filesystem
  
Actual results:

Error unpacking rpm package filesystem-2.4.44-2.fc17.x86_64
error: unpacking of archive failed on file /usr/local/src: cpio: chown
error: filesystem-2.4.44-2.fc17.x86_64: install failed
error: filesystem-2.4.44-1.fc17.x86_64: erase skipped
filesystem-2.4.44-1.fc17.x86_64 was supposed to be removed but is not!

Expected results:

normal upgrade

Comment 1 Ondrej Vasik 2011-08-19 10:32:47 UTC
Thanks for the report. This is not the first report like this ... similar situation with other directories frequently nfs mounted. 

Well - I have no chance to fix that in filesystem package at the moment. Probably worth of some RFE against rpm, I already discussed the similar issue with rpm guy (Jindrich Novy) ... and the decision was NOTABUG in filesystem... see https://bugzilla.redhat.com/show_bug.cgi?id=526368 , https://bugzilla.redhat.com/show_bug.cgi?id=696329 , https://bugzilla.redhat.com/show_bug.cgi?id=538674 and maybe others. You could use rpm option --excludepath=/usr/local/src to avoid the failure.

Filing RFE against rpm was suggested - feel free to do so at http://www.rpm.org/ .

Comment 2 Mark Wielaard 2011-09-05 11:03:22 UTC
(In reply to comment #1)
> Filing RFE against rpm was suggested - feel free to do so at
> http://www.rpm.org/ .

I tried to do that, but even after registering at rpm.org I still get:
"TICKET_CREATE privileges are required to perform this operation" at http://rpm.org/newticket
So I couldn't create a ticket/RFE.
If you do have privileges could you please do so?

Note that this issue was partially solved in with ticket #49
http://rpm.org/ticket/49
But that doesn't seem to be a full solution.

Comment 3 Ondrej Vasik 2011-09-05 15:43:54 UTC
Ok, so what do you want to propose as RFE ? Some option for %dir macro ?

Comment 4 Mark Wielaard 2011-09-06 09:28:49 UTC
(In reply to comment #3)
> Ok, so what do you want to propose as RFE ? Some option for %dir macro ?

I think the easiest would be for rpm to detect that a directory is already there and is currently an active mount point (see man 1 mountpoint). In that case rpm should just warn that it cannot check and set the underlying permissions on the (already existing) dir and continue.


Note You need to log in before you can comment on or make changes to this bug.