Bug 73198 - rpm-4.1 segfaults: READ THIS FIRST
Summary: rpm-4.1 segfaults: READ THIS FIRST
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-31 18:54 UTC by Jeff Johnson
Modified: 2008-05-01 15:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-08 17:52:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeff Johnson 2002-08-31 18:54:45 UTC
This is an umbrella bug to handle various rpm
segfault issues.

The usual cause of segfaults in rpm, unlike most
programs, is bad data either from a package or from
the installed database.

In order to address this issue, rpm-4.1 verifies
all header data when read and written, using digital
signatures and digests if available, otherwise by
doing sanity checks on header data.

So, if you're not running rpm-4.1 and are segfaulting,
the general answer is (or will be) to upgrade to rpm-4.1.

If you need help upgrading, please open an individual bug report.

If not running rpm-4.1, and you're segfaulting while reading
the database, I may need a pointer (i.e. URL, bugzilla attachments
won't work) to a copy of your database to give you a fix:
	cd /var/lib
	tar czvf /tmp/rpmdb.tar.gz rpm

If running rpm-4.1 already, and have a segfault, you
will definitely need to do
	rm -f /var/lib/rpm/__db*
in order to eliminate stale locks. Do that and open
an individual bug report please.

Comment 1 Trevor Harmon 2002-10-02 02:19:01 UTC
I experienced similar problems after upgrading to RedHat 8.0 (although the
problems were likely there already from the previous installation). I could
query and verify packages but not erase them. The issue, as Jeff helpfully
suggested, was due to stale locks in /var/lib/rpm. Removing them solved the
problems.

I can't help but think that RPM could be a little smarter when dealing with
locks. It is already intelligent enough to print an error message when it is run
without the proper permissions (i.e. try erasing a package as a normal user).
Couldn't it also print a warning message when it finds stale locks? That would
have saved me a lot of time hunting down this problem.

Comment 2 Jeff Johnson 2003-03-08 17:52:08 UTC
Closing the umbrella bug. Please open individual
bug reports for rpm segfaults.


Note You need to log in before you can comment on or make changes to this bug.