Bug 73199 - RFE: no virtual screens and workspaces aren't enough
Summary: RFE: no virtual screens and workspaces aren't enough
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: metacity (Show other bugs)
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-31 18:56 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-31 18:56:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-08-31 18:56:50 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
RFE: Virtual screens in window manager, metacity or otherwise.  I have been
unable to find a good way (i.e. not gconf editor) to change my window manager to
test if current sawfish supports virtual screens.  Alternatively, workspaces
could allow moving and stretching apps across workspaces, and scrolling with
mouse between workspaces.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.use metacity as wm
2.
3.
	

Additional info:

We've had virtual screens in fvwm, fvwm2, afterstep, window maker, ..., sawfish.
 It's cruel to take them away now with metacity.  If sawfish still supports
them, that's fine -- but where is something like the old gnome control panel
with an option to change your wm?

Comment 1 Havoc Pennington 2002-09-02 21:42:03 UTC
If this happens it will be on the gnome.org level, not the Red Hat level. 
It's already been much-rehashed though and most likely the answer is 
that viewports will not be in metacity, but may be in other WMs.
A WM-switching UI can't be in the default typical-user-visible control panels
because it's a good way for them to break their desktop; if gnome.org adds an
"advanced power user tweak" tool like Windows XP TweakUI, then it might have it.

(In the meantime it's easy to switch, just kill current WM, run your other WM,
then gnome-session-save.)

WONTFIX because this is best handled upstream not by Red Hat.


Note You need to log in before you can comment on or make changes to this bug.