Bug 732007 - System list throwing error message when no system is registered
Summary: System list throwing error message when no system is registered
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent
Version: 6.0.1
Hardware: Unspecified
OS: Linux
unspecified
low vote
Target Milestone: Unspecified
Assignee: Ivan Necas
QA Contact: Garik Khachikyan
URL:
Whiteboard:
Depends On:
Blocks: katello-blockers
TreeView+ depends on / blocked
 
Reported: 2011-08-19 12:44 UTC by Sachin Ghai
Modified: 2019-09-25 21:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-22 17:53:12 UTC


Attachments (Terms of Use)

Description Sachin Ghai 2011-08-19 12:44:00 UTC
Description of problem:
I registered a system using katello cli and then list the name of system. It was listed properly.

[root@dhcp201-207 katello]# katello -u admin -p admin system list --org=ACME_Corporation
-------------------------------------------------------------------------------------------------------------------------------------------------------------
                                                          Systems List For Org [ ACME_Corporation ]

 Name                               
-------------------------------------------------------------------------------------------------------------------------------------------------------------
 dhcp201-207.englab.pnq.redhat.com  


Later I unregistered it and then again list the name and this time its throwing:

[root@dhcp201-207 katello]# katello -u admin -p admin system unregister --name=dhcp201-207.englab.pnq.redhat.com --org=ACME_Corporation
Successfully unregistered System [ dhcp201-207.englab.pnq.redhat.com ]
[root@dhcp201-207 katello]# katello -u admin -p admin system list --org=ACME_Corporation
error: operation failed: No systems found in organization 'ACME_Corporation', 
[root@dhcp201-207 katello]# 


Version-Release number of selected component (if applicable):
[root@dhcp201-207 katello]# rpm -qa | grep katello
katello-cli-0.1.4-1.git.63.54683c2.fc15.noarch
katello-0.1.64-1.git.0.0b431ff.fc15.noarch


How reproducible:
always

Steps to Reproduce:
1. register a system
2. unregister it; make sure no other system is registered.

  
Actual results:
error: operation failed: No systems found in organization 'ACME_Corporation', 

Expected results:
if no system is registered then on "system list" the message should be like:
No systems found in organization 'ACME_Corporation', 
instead of any error.

Additional info:

Comment 1 Ivan Necas 2011-09-20 12:35:41 UTC
Fixed in edbb2869e43e58a0dbb42acd54d8f18359d8977e

Comment 2 Garik Khachikyan 2011-09-23 13:47:29 UTC
# VERIFIED

fixed - no issue is thrown when there is no system in the list of the org.

A message "No systems found in organization 'ACME_Corporation'," appears instead.

Checked against: katello-cli-0.1.10-1.git.278.85760dc.el6.noarch

Comment 5 Mike McCune 2013-08-16 18:10:40 UTC
getting rid of 6.0.0 version since that doesn't exist


Note You need to log in before you can comment on or make changes to this bug.