Bug 732010 - LDAP+GSSAPI needs explicit Kerberos realm
Summary: LDAP+GSSAPI needs explicit Kerberos realm
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: sssd
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stephen Gallagher
QA Contact: Chandrasekar Kannan
URL:
Whiteboard:
Depends On:
Blocks: 748860
TreeView+ depends on / blocked
 
Reported: 2011-08-19 12:48 UTC by Jakub Hrozek
Modified: 2015-01-04 23:50 UTC (History)
6 users (show)

Fixed In Version: sssd-1.5.1-49.el6
Doc Type: Bug Fix
Doc Text:
Cause: The LDAP provider manual page stated that GSSAPI authentication is used and the Kerberos realm is not specified, the system default would be used. However, the LDAP provider code did not fall back to the system default Kerberos realm when the realm was not specified in the config file. Consequence: The documentation did not match the code Fix: The LDAP provider was fixed so that it is able to fall back to the default realm configured in /etc/krb5.conf Result: The documentation matches the code
Clone Of:
: 748860 (view as bug list)
Environment:
Last Closed: 2011-12-06 16:39:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1529 normal SHIPPED_LIVE sssd bug fix and enhancement update 2011-12-06 00:50:20 UTC
FedoraHosted SSSD 970 None None None Never

Description Jakub Hrozek 2011-08-19 12:48:28 UTC
Description of problem:
The sssd-ldap manual page says:

krb5_realm (string)
     Specify the Kerberos REALM (for SASL/GSSAPI auth).

     Default: System defaults, see /etc/krb5.conf

That's not true since we added the online/offline callbacks to create and delete kdcinfo files. They require the realm to be specified to construct the pathname of the kdcinfo files. 

If the realm is not specified, the provider does not even start and quits with a rather confusing error message (the code strdups the NULL realm and thinks it hits an OOM situation).

Version-Release number of selected component (if applicable):
sssd-1.5.1-47.el6

Steps to Reproduce:
1. configure an LDAP provider with GSSAPI authentication and omit the krb5_realm option
2. start sssd
  
Actual results:
the provider does not start

Expected results:
the provider should start

Comment 5 Kaushik Banerjee 2011-09-30 07:17:25 UTC
Verified in version:

# rpm -qi sssd | head
Name        : sssd                         Relocations: (not relocatable)
Version     : 1.5.1                             Vendor: Red Hat, Inc.
Release     : 52.el6                        Build Date: Tue 20 Sep 2011 09:11:03 PM IST
Install Date: Mon 26 Sep 2011 05:56:30 PM IST      Build Host: x86-010.build.bos.redhat.com
Group       : Applications/System           Source RPM: sssd-1.5.1-52.el6.src.rpm
Size        : 3550647                          License: GPLv3+
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://fedorahosted.org/sssd/
Summary     : System Security Services Daemon

Comment 6 Jakub Hrozek 2011-10-27 14:50:07 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: The LDAP provider manual page stated that GSSAPI authentication is used and the Kerberos realm is not specified, the
system default would be used. However, the LDAP provider code did not fall back to the system default Kerberos realm when
the realm was not specified in the config file.
Consequence: The documentation did not match the code
Fix: The LDAP provider was fixed so that it is able to fall back to the default realm configured in /etc/krb5.conf
Result: The documentation matches the code

Comment 7 errata-xmlrpc 2011-12-06 16:39:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1529.html


Note You need to log in before you can comment on or make changes to this bug.