Bug 732017 - Malloc without NULL check
Summary: Malloc without NULL check
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libunistring
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Stephen Gallagher
QA Contact: Jenny Severance
URL:
Whiteboard:
Depends On:
Blocks: 756082
TreeView+ depends on / blocked
 
Reported: 2011-08-19 13:37 UTC by Michal Luscon
Modified: 2012-06-20 14:16 UTC (History)
3 users (show)

Fixed In Version: libunistring-0.9.3-5.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 14:16:36 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0887 normal SHIPPED_LIVE libunistring bug fix update 2012-06-19 20:47:26 UTC

Description Michal Luscon 2011-08-19 13:37:12 UTC
Description of problem:

libunistring-0.9.3/lib/uninorm/u-normalize-internal.h:311 - Function "malloc" without NULL check.

/lib/uninorm/uninorm-filter.c:241 - Function "malloc" without NULL check.

Version-Release number of selected component (if applicable):
0.9.3-3

Additional info:
These defects were found by the analysis of Coverity scan results.

Comment 5 Jenny Severance 2012-05-29 12:38:02 UTC
verified sanity only :: testing done with system testing of SSSD :: no regressions found.

Comment 6 errata-xmlrpc 2012-06-20 14:16:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0887.html


Note You need to log in before you can comment on or make changes to this bug.