This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 732030 - IOException with Drift
IOException with Drift
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.1
Unspecified Unspecified
high Severity high (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 707225
  Show dependency treegraph
 
Reported: 2011-08-19 10:24 EDT by Mike Foley
Modified: 2012-02-07 14:26 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:26:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Drift io exception (12.67 KB, text/plain)
2011-08-19 10:24 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-08-19 10:24:27 EDT
Created attachment 519047 [details]
Drift io exception

Description of problem:  IOException with drift


Version-Release number of selected component (if applicable):
8/19 build


Steps to Reproduce:
1.  basic drift use-case ... 
2.  drift config
3.  edit 1 file that is under drift detection
  
Actual results:
IOException in RHQ Server log.  no customer facing impact, afaik

Expected results:
no exceptions in server log

Additional info:  attachment showing error
Comment 1 John Sanda 2011-08-25 10:29:55 EDT
This was a result of prematurely closing the input stream from the zip file containing the change set report. The change set reader was closing the stream after reading the file. This was a problem because the method used to traverse the zip file, ZipUtil.walkZipFile, expects the stream to remain open, and it handles closing the stream. This didn't cause any loss of functionality because we only send one change set report per zip file. 

This issue has been fixed by explicitly telling the change set reader not to close the stream.

commit hash: 1fac1f54c438561b1c1907719d55b03f88e8aa43
Comment 2 Mike Foley 2012-02-07 14:26:04 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.