This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 732087 - Missing gzip_stream.h in protobuf-devel
Missing gzip_stream.h in protobuf-devel
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: protobuf (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Pierre-YvesChibon
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 678809
  Show dependency treegraph
 
Reported: 2011-08-19 14:15 EDT by Sébastien Willmann
Modified: 2011-10-09 15:42 EDT (History)
4 users (show)

See Also:
Fixed In Version: protobuf-2.4.1-2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-08 13:59:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sébastien Willmann 2011-08-19 14:15:18 EDT
Description of problem:
The file gzip_stream.h is not in the package protobuf-devel. I think it misses zlib as a BuildRequire.

Version-Release number of selected component (if applicable): 2.3.0-7
Comment 1 Pierre-YvesChibon 2011-09-06 09:52:12 EDT
ping ?

This blocks the review for a new package...
Comment 2 Conrad Meyer 2011-09-06 13:08:01 EDT
(In reply to comment #0)
> Description of problem:
> The file gzip_stream.h is not in the package protobuf-devel. I think it misses
> zlib as a BuildRequire.
> 
> Version-Release number of selected component (if applicable): 2.3.0-7

First: Sorry, I've been busy and then offline (moving) and won't have regular internet capabilities until at least Thursday.

I'm confused why this is broken now. zlib is a dependency of gcc, which falls under http://fedoraproject.org/wiki/Packaging:Guidelines#Exceptions_2 ; zlib-devel doesn't include a gzip_stream.h header.

In fact, nothing seems to include a gzip_stream header:
$ repoquery -qf /usr/include/gzip_stream.h
No package provides /usr/include/gzip_stream.h
Comment 3 Sébastien Willmann 2011-09-06 16:39:52 EDT
The problem is not that protobuf-devel requires this file, but that it should provide it. See http://code.google.com/intl/fr/apis/protocolbuffers/docs/reference/cpp/google.protobuf.io.gzip_stream.html

Of course, the missing BuildRequire is zlib-devel and not zlib as I said.

Sorry if the description was not clear enough.
Comment 4 Pierre-YvesChibon 2011-09-15 07:01:56 EDT
So what do we do ?
Comment 5 Sébastien Willmann 2011-09-15 16:48:03 EDT
I built the package with mock adding zlib-devel as a BR, and gzip_stream.h appeared in protobuf-devel. So I confirm that zlib-devel should be added as a BR.
Comment 6 Pierre-YvesChibon 2011-09-25 14:38:36 EDT
Since the only change needed is a rebuild with the new BR and I have provenpackager rights. Would you like me to take care of the rebuild ?
Comment 7 Conrad Meyer 2011-09-26 18:57:35 EDT
(In reply to comment #6)
> Since the only change needed is a rebuild with the new BR and I have
> provenpackager rights. Would you like me to take care of the rebuild ?

Yes, please. (Sorry, very busy lately...)
Comment 8 Pierre-YvesChibon 2011-09-27 15:21:25 EDT
Thanks, will do :)
Comment 9 Fedora Update System 2011-09-28 04:11:14 EDT
protobuf-2.3.0-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/protobuf-2.3.0-8.fc15
Comment 10 Fedora Update System 2011-09-28 04:11:36 EDT
protobuf-2.4.1-2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/protobuf-2.4.1-2.fc16
Comment 11 Fedora Update System 2011-09-28 14:50:08 EDT
Package protobuf-2.4.1-2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing protobuf-2.4.1-2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/protobuf-2.4.1-2.fc16
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2011-10-08 13:59:06 EDT
protobuf-2.3.0-8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2011-10-09 15:42:38 EDT
protobuf-2.4.1-2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.