This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 732102 - Drift detection does not resume after agent restart (with --cleanconfig)
Drift detection does not resume after agent restart (with --cleanconfig)
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: drift (Show other bugs)
4.1
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 707225
  Show dependency treegraph
 
Reported: 2011-08-19 15:29 EDT by Mike Foley
Modified: 2012-02-07 14:31 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2011-08-19 15:29:18 EDT
Description of problem:  Drift detection does not resume after agent restart (with --cleanconfig)


Steps to Reproduce:
1.  shutdown agent
2.  edit a file that is in a folder being watched by drift detetection
3.  restart agent with --cleanconfig
Comment 1 John Sanda 2011-08-25 10:36:06 EDT
When the agent restarts, it does get resources' drift configuration during inventory sync; however, it does not get the corresponding drift detection schedule because those only exist on the agent. The impact of this is that restarting the agent with --cleanconfig means the schedule will be "reset". To be clear, this only impacts when the next scheduled detection will occur.
Comment 2 John Sanda 2011-09-15 17:01:00 EDT
Code is now in place to support syncing drift configurations when the agent is started either with a purged local inventory or an existing local inventory.

commit hash: 6f788d1ec4e183b26483267e9653dada84ea2b1a
Comment 3 Mike Foley 2011-09-16 11:07:13 EDT
TCMS testcase added.

verified 09/16/2011 RHQ 4.1 daily build.
Comment 4 Mike Foley 2012-02-07 14:31:35 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE
Comment 5 Mike Foley 2012-02-07 14:31:37 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.