Bug 732103 - package --cvs does not work with 'web_version_label: UNUSED'
Summary: package --cvs does not work with 'web_version_label: UNUSED'
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: publican
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ruediger Landmann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 19:32 UTC by Deon Ballard
Modified: 2011-08-19 19:35 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-08-19 19:35:06 UTC


Attachments (Terms of Use)

Description Deon Ballard 2011-08-19 19:32:26 UTC
If I try to publish a doc with the line 'web_version_label: UNUSED', then it gives an error because it incorrectly tries to check out a non-existant CVS directory.

I am seeing this on the Customer Portal doc for Red Hat Network Certificate-based Subscription Management.

The tool is creating the proper src rpm:
Red_Hat_Customer_Portal-Red_Hat_Network_Certificate-based_Subscription_Management-1-web-en-US-1-1.1.el5.src.rpm

But then it is looking for a CVS module without any numbers:

cvs command: cvs -d :ext:cvs.devel.redhat.com:/cvs/dist co Red_Hat_Customer_Portal-Red_Hat_Network_Certificate-based_Subscription_Management--web-en-US-DOCS-RHEL-6

Since 'Red_Hat_Network_Certificate-based_Subscription_Management--web-en-US' doesn't exist, the checkout fails.

This is using publican-2.6-3.el6eng.x86_64 on RHEL 6.1.

Comment 1 Deon Ballard 2011-08-19 19:35:06 UTC
And, as always, this was my fault. I had an error in my cfg file.


Note You need to log in before you can comment on or make changes to this bug.