Bug 732118 - [abrt] meld-1.5.2-1.fc15: diffutil.py:223:get_chunk:IndexError: list index out of range
Summary: [abrt] meld-1.5.2-1.fc15: diffutil.py:223:get_chunk:IndexError: list index ou...
Keywords:
Status: CLOSED DUPLICATE of bug 682647
Alias: None
Product: Fedora
Classification: Fedora
Component: meld
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dominic Hopf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:53c88c354041698e788a7f0cb30...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-19 20:44 UTC by eduardovra
Modified: 2012-03-06 14:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-06 14:06:32 UTC


Attachments (Terms of Use)

Description eduardovra 2011-08-19 20:44:06 UTC
abrt version: 2.0.3
architecture:   i686
cmdline:        
comment:        i dont know
component:      meld
executable:     /usr/bin/meld
kernel:         2.6.40-4.fc15.i686
os_release:     Fedora release 15 (Lovelock)
package:        meld-1.5.2-1.fc15
reason:         diffutil.py:223:get_chunk:IndexError: list index out of range
time:           Fri Aug 19 17:43:43 2011
uid:            500
username:       eduardo

backtrace:
:diffutil.py:223:get_chunk:IndexError: list index out of range
:
:Traceback (most recent call last):
:  File "/usr/share/meld/meld/filediff.py", line 464, in on_current_diff_changed
:    chunk0 = self.linediffer.get_chunk(chunk_id, 1, 0)
:  File "/usr/share/meld/meld/diffutil.py", line 223, in get_chunk
:    chunk = self._merge_cache[index][sequence]
:IndexError: list index out of range
:
:Local variables in innermost frame:
:from_pane: 1
:index: 0
:self: <Differ object at 0x89e17d4 (meld+diffutil+Differ at 0x8b828c0)>
:to_pane: 0
:sequence: 0

Comment 1 Yaniv Kaul 2012-01-03 07:32:13 UTC
Compared files, they were identical, removed filters, still identical, exited the program.

rating: (null)
Package: meld-1.5.2-1.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment 2 Michael Spahn 2012-03-06 14:06:32 UTC

*** This bug has been marked as a duplicate of bug 682647 ***


Note You need to log in before you can comment on or make changes to this bug.