Bug 732154 - Chmsee breaks after mozilla xulrunner update
Summary: Chmsee breaks after mozilla xulrunner update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: chmsee
Version: 15
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Yijun Yuan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 751939 754486 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-08-20 03:05 UTC by nomnex
Modified: 2012-01-25 07:37 UTC (History)
7 users (show)

Fixed In Version: chmsee-1.99-0.6.5.git7fb12b8.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-12-06 01:04:55 UTC


Attachments (Terms of Use)

Description nomnex 2011-08-20 03:05:48 UTC
Hi, this is for Peng Wu

see bug https://bugzilla.redhat.com/show_bug.cgi?id=717130. The same problem occurs again. Thanks in advance.

Installed Packages
Name        : chmsee
Arch        : i686
Version     : 1.3.1.1
Release     : 2.fc15
Size        : 383 k
Repo        : installed
From repo   : updates-testing


[mt@nh28d linux]$ chmsee

** (chmsee:6264): WARNING **: GECKO_UTILS >>> Couldn't find a compatible GRE!


** ERROR **: Initialize html render engine failed!
aborting...
Aborted (core dumped)
[mt@nh28d linux]$

Comment 1 nomnex 2011-08-25 01:05:46 UTC
May I request a xulrunner update of the chmsee package, and wouldn't it be advisable to use 2 packages, as explained in the answer below, to avoid further breakage after a FF update? In advance, thanks for your time.

--- Copy of the answer on code.google ---

http://code.google.com/p/chmsee/issues/detail?id=134

Sorry about this buggy software:(

After mozilla upgrading to xulrunner 5.0, the gtkmoz-embedded component which chmsee 1.3.* depended is dropped. I guess the old patch (https://bugzilla.redhat.com/show_bug.cgi?id=71713) is still worked with the old xulrunner. When you update Fedora, the old xulrunner gone, the dependence is broken, chmsee cannot launch again.

Some distributions maintain two different versions xulrunner to support some old packages. I recommend you to find whether there is an old xulrunner lib (maybe named libxul) existed in Fedora 15.

Comment 2 Peng Wu 2011-08-25 02:25:45 UTC
Sorry, the xulrunner 6.0 has changed many contents, such as remove GRE functions.
I tried to force chmsee compile with xulrunner 6.0, but still crashes when launch.
the libxul is named xulrunner in Fedora.

As chmsee 2.0 will switch to use xulrunner 6.0, Please wait for chmsee 2.0 release.
Or you can compile the v1.99.05 by yourself, see chmsee README.

Comment 3 nomnex 2011-08-29 08:51:03 UTC
(In reply to comment #2)
 
> As chmsee 2.0 will switch to use xulrunner 6.0, Please wait for chmsee 2.0
> release.

Thank you Peng. I will wait for v 2. Will it be available through testing-update on Fedora 15?

Comment 4 Peng Wu 2011-08-29 09:00:29 UTC
(In reply to comment #3)
> Thank you Peng. I will wait for v 2. Will it be available through
> testing-update on Fedora 15?

As chmsee 2.0 is not released yet, hard to predict.
But if possible, I will try to update it for Fedora 15.

Comment 5 nomnex 2011-09-01 05:18:57 UTC
Thanks for the feedback, Peng. I hope I will read my chm books in chmsee again.

Comment 6 tha.alkaholik 2011-10-07 09:47:32 UTC
I had the same bug here, I think it works if GRE_HOME is set to point to xulrunner:

$ GRE_HOME=/usr/lib/xulrunner-2/ chmsee 

I hope to know why it works if it does !!

Comment 7 Peng Wu 2011-10-10 02:36:46 UTC
I got the result:
$ GRE_HOME=/usr/lib64/xulrunner-2/ chmsee
Segmentation fault (core dumped)

Comment 8 Yijun Yuan 2011-10-10 10:02:03 UTC
@pwu do you think it is a good idea to push 1.99? I have them built on koji.

Comment 9 Peng Wu 2011-10-11 02:34:11 UTC
I think it is good to push it on F-15/F-16, as currently chmsee can't be launched on F-15.
Please update chmsee for Fedora, Thanks very much.

Comment 10 nomnex 2011-10-14 10:35:47 UTC
great, Yuan, can you post back when the package is available in bodhi.

Comment 11 nomnex 2011-11-08 01:30:17 UTC
Yuan Yijun, any update about chmsee 1.99 package for F-15? Thanks

Comment 12 thxdoom 2011-11-09 05:00:20 UTC
*** Bug 751939 has been marked as a duplicate of this bug. ***

Comment 13 Yijun Yuan 2011-11-09 05:14:28 UTC
@nomnex just submitted to bodhi..

Comment 14 nomnex 2011-11-09 06:00:32 UTC
@Yuan, great, thanks!

Once it has been pushed (True), the command to test it is:
# su -c 'yum update --enablerepo=updates-testing chmsee-1.99-0.4.5.git7fb12b8.fc15'?

Comment 15 Peng Wu 2011-11-17 02:42:16 UTC
*** Bug 754486 has been marked as a duplicate of this bug. ***

Comment 16 nomnex 2011-11-17 03:10:47 UTC
https://admin.fedoraproject.org/updates/search/chmsee?_csrf_token=a9154788ec3dc35ac9cdbdb5d8debfcf2afc67e8

I don't see the chmsee-1.99-0.4.5.git7fb12b8.fc15 anymore?

Comment 17 Yijun Yuan 2011-11-17 03:43:52 UTC
@nomnex I withdrew the updates because it will not work for xulrunner-8, another build is necessary. But I haven't submit the new build either..

Comment 18 nomnex 2011-11-17 09:26:34 UTC
(In reply to comment #17)

> another build is necessary. But I haven't submit the new build either.

Thank you for the answer. Firefox 8 is still in testing repo. Do you plan to build Chmsee w/xulrunner-8?

What's the life span of a FF version today? Chmsee will have to be re-build with xulrunner-9 once FF9 is out. Is that correct?

Comment 19 Yijun Yuan 2011-11-17 14:03:23 UTC
Hope chmsee-2.0 will release before FF9. :)

Comment 20 Fedora Update System 2011-11-17 14:14:28 UTC
chmsee-1.99-0.6.5.git7fb12b8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/chmsee-1.99-0.6.5.git7fb12b8.fc15

Comment 21 Fedora Update System 2011-11-17 14:14:36 UTC
chmsee-1.99-0.6.5.git7fb12b8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/chmsee-1.99-0.6.5.git7fb12b8.fc16

Comment 22 Fedora Update System 2011-11-19 05:56:15 UTC
Package chmsee-1.99-0.6.5.git7fb12b8.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing chmsee-1.99-0.6.5.git7fb12b8.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16072/chmsee-1.99-0.6.5.git7fb12b8.fc16
then log in and leave karma (feedback).

Comment 24 Borut Semenic 2011-11-23 09:21:03 UTC
On Fedora 16 

chmsee-1.99-0.6.5.git7fb12b8.fc16
 - now starts but does not open any chm file only welcome screen is present, no errors is shown when it is started from terminal. xchm open chm files normally

Comment 25 Fedora Update System 2011-12-06 01:04:55 UTC
chmsee-1.99-0.6.5.git7fb12b8.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 26 Fedora Update System 2011-12-06 01:07:12 UTC
chmsee-1.99-0.6.5.git7fb12b8.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 27 nomnex 2011-12-23 10:26:29 UTC
Firefox 9 is out. Is Chmsee going to break again, as soon as F9 is the Fedora repo?

Comment 28 Yijun Yuan 2011-12-23 15:43:35 UTC
(In reply to comment #27)
> Firefox 9 is out. Is Chmsee going to break again, as soon as F9 is the Fedora
> repo?

probably yes.. I've no idea how to request a synthetic build..

Comment 29 nomnex 2011-12-25 22:11:04 UTC
Is it okay to ask you for a build update, if F9 xlrunner breaks chmsee?

Comment 30 Peng Wu 2011-12-26 02:36:04 UTC
(In reply to comment #28)
> (In reply to comment #27)
> > Firefox 9 is out. Is Chmsee going to break again, as soon as F9 is the Fedora
> > repo?
> 
> probably yes.. I've no idea how to request a synthetic build..

Maybe you could try to use http://fedoraproject.org/wiki/Bodhi/BuildRootOverrides.
Before you build chmsee, use bodhi to check whether xulrunner 9 is in Koji Buildroot Overrides.

Comment 31 nomnex 2012-01-25 07:37:25 UTC
FF9 is out, in the stable repos.
Chmsee is broken again.
Do I need to open a new bug?
Thanks.


Note You need to log in before you can comment on or make changes to this bug.